WDTV Live suddenly does not detect network shares


I upgraded from my original WDTV Live to the latest version.  The first week of using it, I had no problem connecting and streaming my media from my PC.  About 10 days ago suddenly when I tried to stream, after clicking “Videos”, I got the message, “The previously selected content source has been disconnected…”.  I hadn’t changed a single setting between the last time it was working until now.  I attempted to go into my PC and reshare all the shared folders I had set, and I still receive the same message.

Anyone have any suggestions for a fix for this issue?  Thanks.

Shut down the WD, pull its plug.

reboot your PC.

wait 5 minutes.

Restart your WD.

Go to Settings then network settings, go down to second page, clear network share login, do this

cma, I am willing to bet you are running Windows 7 or newer on the network share. This forum is replete with tales of people with the same problem.

I’ve had the same behavior. I’ve tried all the steps, including experimenting with the Master Browser stuff. The problems started after upgrading my server PC from XP to Windows 7. Just for fun, I hooked up the old XP box and, lo and behold, that share always shows up.

Anyway, here is what I did, this may or may not be something you decide is helpful. I use a media server to serve up my music and pictures. That works fine. But serving movies via a media server, while more reliable from an access standpoint, is not acceptable to me because I lose all the XML descriptive content (plot, etc.) that accompany each file. So I decided to simply attach an external 2TB hard drive (which I already had) and use that for movies only. 

The upside of this setup is the external HD is accessible via the network if I want to either access a file from another PC or push new files to the unit. Plus all my movie browsing is quicker than it was over the network share.