WDTV live keep asking for username and pass in windows network

I’ve run out of ideas. Everything is exactly as it should be apparently.

  • Both pc and wdtv are set to WORKGROUP
  • pc can ping and open webpage for WDTV. WDTV can access media server on pc
  • network discovery is on
  • file and printer sharing is on
  • public folder sharing is on
  • WDTV can stream stuff off the internet
  • Other media player can access network share on PC
  • WDTV can access winxp64 when booted.
  • Network share server on WDTV is turned on (no protection)
  • Running latest firmware on WDTV
  • Tried turning off firewall… no dice.
  • Netbios over tcp/ip is turned on.

-the windows network is fully functional, others pc can read and write files.

-my 2 other pc can be viewed from the wdtv, but my main pc dont.

-all folder permisions are set to everyone, and administrators.

When I select to connect to a network share on WDTV I keeps to ask me for username and password.

I have tried everything. Anonymous, guest account, even new user accounts to log in.

Strange thing is that I have 2 other pc with win7, and both can be accesed from the WDLIVE, but my own pc, wich is the ms browser, cant!

I assume that you have tried the default information and have attempted to connect without changing any of that info.

If you have changed it you may want to go to the setup and clear the network login.

You could also try resetting to factory defaults in the setup menu.


I already done that several times. Clear the network info, and reset to factory settings.

On the screen where you type in the login-info, there’s a checkbox at the bottom to remember the login-info. You might want to check it… :wink:

I had this after latest FW update. Took a while but I had to follow this from a post on another site. Not linked to WD but  my Live showed my shares and worked perfectly after following the instructions.


Anyway worked for me so I hope this might help others.

I have 3rd gen WD Live, PC with Win 7 networked by Lan.

Nobody works, sadly. I tried to rollback several firmwares and is the same problem again and again.

I cant understand why it works in my others pc, and in the main one doesnt. All the settings are exactly the same.

Problem solved. My router is blocking the acces to my pc, for some reason, Now is working fine with the last firmware.

thank you all.