WDTV Live Hub not detected in Windows 10

I’ll try to explain it as much as i can

Back then, on Windows 7, i was able to just install the WD Discovery program and instantly access the WDTV Live Hub device connected via LAN after some configuration etc and worked great for years. I could access the drive via the WD Discovery program or heading to My Computer’s Network part at the left side of the window

Less than a week ago i’ve made a clean install and installed Windows 10…Though i’m happy with the system, there’s a HUGE ISSUE WITH IT…and WD Discovery (In it’s newest version?. The one with a white background look, not the darkish black with white stuff around) can detect the drive…Yes…But the only options avaliable in black are “Configure” and to put a shortcut to the desktop… The “Explore shared network folders” (THE IMPORTANT ONE) and the other option are greyed out…

In the old version of WD Discovery (Black UI one) the explore folders option is there avaliable, but…Once i click it, it gave me an error that i don’t remember

Not even the device is detected as a NETWORK DEVICE… Instead, if i go to My Computer, under “Network Ubication” or something (Spanish OS) there’s the device, yes…BUT I CAN’T PUT STUFF IN IT!!

If i go to the Network area, there are 2 WDTVLiveHub icons, one for the device’s “Self IP Menu” (the one that asks you to put admin as a password) and the other one sends you to Twonkymedia…

Is there something that i can do to make it work again?, or do i have to roll back to Windows 7 to make it work?


EDIT: I went back to Windows 7 and it works back again with the Black UI.

Maybe dunno, WD could give some support to Windows 10 and make a new WD Discovery + Drivers within such compatible for Windows 10+WDTV Live Hub some day?. The last updates were from 2014 and W10 got released last year… I tought WD would move on about it ^^;;;

Unfortunately, the WD TV Live Hub HD Media Center is not supported under Windows 10 at the time of this post. The best bet would be to manually map the unit’s main share through your network. The network paths you found are related to the unit’s management and DLNA features, not the storage volume itself (Try \theipaddressofyourunit in the search box).

Guess i’ll stay in W7 until WD does something about it…HOPEFULLY, it’s been +2 years without updates on such drivers yet nothing about W10.

I’ve tried alternatives but nothing worked from this forum