WDTV Live Hub got reset?

Hi all,

I have the Live Hub and other than it’s a bit slow at times, I love it.

Last night I turned on my unit with an attached WD 3TB drive and everything on the Hub was reset to factory settings.

I had to go in to the options and set everything back up again.  I did not lose any files on either drive but found it to be a bit weird.

Anyone know why or how this could have happened?  I am the only one using the unit so if I did not do anything, then nobody else would have.

Also, I am looking at adding a WDTV Live (without the 1TB) to my network.  Was just wondering if I could access everything on my Live Hub and 3TB drives from the new unit.  The 3TB drive is not a networked drive but I have mapped it to the Live Hub.  Curently, my XBOX 360 only recognizes the Live Hub and not the attached 3TB HD.  Many thanks.

When you say you turned it on, was it just in standby or had you unplugged it or turned it fully off?

The hub is meant to be put to sleep by a single click of the power button on the remote. If you hold it for more than that or turn it off at the wall, it will reset its self on reboot.

As for the speed, take a look at alaska theme. I had the same problem, and it seems to be that any theme including the default that use movie sheets (where it tells you all about the movie then has those changing background pictures), connects to the internet every time the picture changes. Alaska does’nt use movie sheets and is a **bleep** of a lot faster. Take a look under the themes section of the forums here. Its really quite nippy with that theme.

I have the WD TV Live media streamer also, I dont have a usb drive plugged into my hub but the live streamer will access everything thats on my hub, so don’t see why it would’nt see the attached drive, i’ll have to check that.

Thanks for the reply, I’ll check out what you told me about the speed.

I only turn the unit on and off with my Harmony remote so holding the button down never happened.  As long as I did not lose any movies, I’m okay with it.

Thanks for the reply!


This is not correct. Holding down the power button for several seconds does shut down the HUB completely so it can not longer act as a NAS, but it will not reset to the factory settings. I power down my HUB all the time and do not lose any of my settings, it just takes longer to turn on as it reboots and does an update of the media library.


Your HUB should hold your settings (account info, views, Themes etc) regardless of if you go into standby mode or ccomplete shutdown.





Narny wrote:


The hub is meant to be put to sleep by a single click of the power button on the remote. If you hold it for more than that or turn it off at the wall, it will reset its self on reboot.


I have the same problem that my WD Live Hub loses its network settings frequently and sometimes even all settings (timezone/sharing/media library) I don’t know, how often I have re-entered it so far… :confounded:

Maybe it’s the network connection losing the DNS, maybe it’s the newest firmware causing the problem. I have tried fixed and reserved IP settings, different media library and share settings and so on… nothing helped. The device is getting stuck from time to time and the only way to solve it is powering it on and off and re-enter all settings.

Maybe one of you experienced the same problems and solved them. I would be happy for any help. Otherwise I need to switchh to another brand HD Mediacnter… :frowning:

I am having the same problem.  My WD TV Live Hub keeps losing the setting (Network [IP, mask, Gateway, DNS], time zones, NAS, DNLA, iTune, appearance, audio, etc.).  Between my entertainment PC and the WD TV Live devices I had a nice setup with SABnzbd, SickBear, and Plex going, but it looks like I am going to be forced to go back to the setup I had before (my PC/TV setup). I really liked the capabilities mix between SABnzbd, Plex and WD TV Live Hub.

I have WD TV Live and a WD TVLive Hub with a 3TB USB drive connection.  I am disappointed that the setup is not working and I am getting tired of reentering all the settings on the WD TV Live Hub.

Any suggestions?


I have a problem with the Hub defaulting the video settings back to 480p from 1080p. I have gotten in the habit of checking before I start watching anything to make sure it has not done it again, but every 2-3 times of use I will find it reverted back to SD video. Very annoying.

The problem still present with no solution or recommendation from the WD TV Live Team.  It sure looks like WD is monitoring these threads at all, this is pretty bad.   I guess I am going to have to move to plan B:  Replace all three WD TV Live devices I own with something much more stable and relible…simply too bad that I wasted my money.

I wonder if some of these units might just have a bad/flakey reset buttons… Hey, they had some really bad power buttons on some of them…

If mine were acting like this I would at least try unplugging the hub and tapping the reset button a few times to see if it feels like it might be sticking on ocassion.

I too am having this issue!  I was in love with this unit until today.  Everything is reset and I can’t even reset my timezone!  Any fix to this?!  I guess this unit was too good to be true.  :cry:

My brand new HUB has the same problem :cry:

I am now having the same issue and it is now happening every day.  All my settings get lost, network settings, time zone, everything gets lost and I have to reset it all and rebuild the Library all over again.