WDTV Live Hub freezing/crashing

I apologize if this has already been answered here, but I could not find anything pertaining to my problem and I am pressed for time so I decided to post my specific issue.

I have my Live Hub attached to a usb2 2TB WD LiveBook full of movies, music, etc.  At first it worked great, but after a while the system seems to get bogged down and everything takes longer and longer to get through menus and start playing things… now it is to the point where the Live Hub freezes so completely that I have to unplug the power and plug it back in to get it to work… and then it only freezes again after a few minutes.  At first I thought it was something to do with the “Compiling media library” because it has *never* stopped finishing this function despite letting it sit idle for days (it usually ends with the media player freezing up even without anyone tampering with it).  But I’ve tried turning off the media library and it still freezes.  I reset to factory settings everything but the network (which works fine) and that seemed to solve my issues for a while, but as soon as it started trying to read my attached USB, the issues began to arise again… sluggish menu changes… freezing… etc.  

On a only slightly related note, when I *do* get the device to work for a bit, I try to use the “Get Info” option to add pictures/info to my movie collection, but that option has disappeared for me since the last patch… thought I might as well try to get an answer for that as well.

I would really appreciate some help with this because if I cannot play properly of my LiveBook, it is a deal breaker for keeping this device… which I really liked at first.  My problems have been going on for over a week now, by the way.

connections:

WDTV connected to USB2 2TB Live Book

ethernet cable attached to AT&T Uverse cable box (network seems to be fine, though)

connected to receiver via HDMI which is connected to my HDTV

I’ll be happy to provide any more information that is necessary.

"because it has *never* stopped finishing"

I have 1xWD Elements 2TB, and a 1TB My Book plugged into the USB ports.

A 300 GB computer share, and a Samsung Story 1.5 Tb USB share from my PC.

When I do a full restart, it compiles it all in a couple of minutes, then when I select All storage/ Network Share, it takes another minute or so to compile that.

No wonder its sluggish, as Im guessing you are going in and out of folders when it is still trying to compile, and if you are having to pull the cord, this is not good for anything either, especially if its still trying to read what’s on your drive.

I don’t know exactly what is happening, but try and connect your USB drive to a PC and fix and defrag if reqd.

I would then do a factory reset, Power down, then connect the USB drive and see where you stand.