WDTV LIVE HUB as standalone NAS for Marantz melody 610

Sorry im new to this - so ill hopefully be specific to what my issue it.

I have had a wdtv live hub (1tb) for sometime and love it - it plays everything you throw at it. I have network sharing etc set up and stream fine from my laptop.

I recenently purchased a marantz 610 music streamer - and set it up fine playing all my airplay iphone stuff and plaing files on my computer using network share. What I wanted to do was now use my wdtv’s hardrive as a NAS so i can access music directly off that without having my laptop switched on. Is this possible?

I also have tried to set up the twonky server on the wdtv home page but fails to launch eveytime. This web page is not available ERR_CONNECTION_REFUSED

(ive tried rolling back firmware but no joy) Is what I want to do possible? if so could someone please help, it would be much appreciated.



Hi oussed, welcome to the WD Community. Any device on the same network that is capable of accessing network shares or a media server should be able to access the Live Hub. Have you tried to do a factory restore? 

and you’ll have to set DLNA-mediaserver to ON in the LIVEHUB’s network settings. i can confirm that i use my LIVEHUB the same way you’re wanting it to. all DLNA devices at home use the LIVEHUB as a media-server/NAS.

Thanks for your reply - I have these settings as suggested, I still cannot pick the WDTV Hub up on my music player. I does show up in the network area of windows 7 , and I can access the drive via my laptop. I thought it was something to do with the twonky server - as it wont launch. I have tried a factory reset but it hasnt worked.

So you have set

Settings\Network Share Managment\DLNA Media Server\ON?

Twonky should accessible on your network within few minutes. Also it needs some time to scan your files on Hub.

yes DLNA Media Server is on. and media to launch twonky and it comes up with on 

This web page is not available



So I cannot launch it for some reason. Im not sure whats going on. Appreciate your help guys

This might sound crazy but it helped someone before. Rollback firmware
and than update to the last one.

Ive already tried that the issue and still seems that twonky is down - or is for me at least. 

Sorry, missed that. Strange :frowning:

strange, really.

found these threads in this forum, maybe some more ideas for you, coming with images and hopefully with solutions.



Did you tried deleting hidden folders on internal HDD? They have dot in prefix.

Thanks for help guys. I did try this but in my computer its not showing as a twonky server only the wdtv as a network drive and device.

I have seen that there are some different results with cabled and wifi - I might try using the wifi  dongle just as a matte rof interest rather than ethernet cable and give it a go.

I will also try and reset the device again just to make sure…Other than that typing in the twonky ip directly never worked…

Tried deleting folders, wifi dongle and another re-set. No twonky server showing in netwok, and still cannot launch.

I think I might have to buy a new NAS