WDTV HD Gen 2 - Suddenly not supported on multiple HD TVs


I have a 2nd Gen WDTV Media Player that has worked great for about 2-3 years now. I have 2 HD TV’s (1 plasma Sylvania and 1 LCD Samsung). I switch it from TV to TV now and then. Out of no where last week, the media player shows “Mode Not Supoorted - The resolution is not supported on this TV. Please change the resolution.”

  • This shows on both TV’s, and have tried different HDMI ports on both TVs

  • Tried resetting it a million times, both 2 second and 10 second counts

  • Tried different HDMI cables

  • Resetted to factory defaults, the media player and both TVs

  • Media player is up to date on firmware

  • For years it has played 1080p media no problem, through HDMI

  • Tried unplugging/plugging, resting 10mins, 1 hour, 1 day

  • Works with composite cable… tried setting resolution to 1080, but when I then switch to HDMI source, I get same “Mode Not supported” message. (you have to unplug composite for HDMI to work) 

  • Tried glitching it back to normal (unpluging during reset, factory reset) but still nothing

Anyone know what happened? :frowning: I love this little machine and I’d hate to spend another $100+ on the newer Live edition. 

I was checking other posts from users with your same problem, not necessarily the Gen2, and apparently there is not a solution, you may request a replacement, if still in warranty, or purchase a new player.