WDTV doesn't find hard drive connected to router

Hi all,

I have exactly the same problems as described. (WD4300).

Just some comments:

  • The route does have an SMB client. (at least some details for USB network config are in the FAQ manual, but it does not help in this case.

  • The direct address to the router sharedrive is: \\volume1 (but I found no option to key in this directly into my WD TV Live), there is NO option in the router to set the workgroup, PC will also not LIST this share but can connect when directly accessing the share address (see below)

  • MKV (in my case MP4 - H264) won’t play back by media server (only audio) but it’s strange, because I see the video in the background of some menus.

  • You can connect the HD drive to the WD-TV live and use it as NAS just as if connected to the router and connect as network drive on the PC
    (This works with my hardware. In this case I observe the USB connection to be lost when I write (download) and playback video at the same time. That’s why I was trying to use the setup as described here in the beginning. Maybe try if it works for you)

Thanks for your reply!

Yes, sounds exactly like my problem.

Unfortunately I don’t have a solution yet and TP-Link doesn’t like its E-Mail support, it seems. Or they don’t have one…

As for the firewall: I tried to shut it off several times, doesn’t make a difference :frowning: I think with this router, for whatever reason, it doesn’t work. It should though, so I’m trying my best to get an answer from TP-Link. If I do know something, I’ll let you know. Please do the same, if you have any other hint!


Can u get other router and try. See if u get temp or carry your wdtv to see your friend house. This way we can confirm.it is is tplink issue. Dont need to say other router should have usb port.

@ Adaneth


Sure I will post here if I find a solution. I just send a request to the TP-Link Support before seeing your answer here. Maybe one of us is lucky or they notice at least that it is not just a problem of a single user.


Have you also tried attaching the Storage drive directly to the WD-TV live?
An did you also have the problem that the device is “auto detached” when doing read & write at the same time ? (For this issue I was not sure if my mediaplayer may be broken of if this is a general weakness of this version. Previos version did not have this, but had other prroblems)



@ travel_living

With an other router it will probably work. But I don’t want to buy another one if there is a chance to get this running.

Nevertheless if someone has a router and made this configuration work: please post.

I managed to access an USB storage device that is connected to a 2nd WD-TV live mediaplayer in the same network without issues. That means, the solution can work as long as the configuration of the “NAS” device is OK (which of course could need a fix in the firmware of this device).


Well I didn’t try to connect it directly to the WDTV, because this setup wouldn’t work for me. I want to have my HDD with my PC in my office, which is the room next to the living room, where the TV and also the WDTV is. It’s no use for me to have my HDD at the TV, cause I constantly need to access it with my PC.

Any response from TP-Link support yet? I didn’t receive anything…

Nothing from TP-Link.

Does anyone know an affordable router that works and can share a NAS to my WD-TV Live ?

On the other side: connecting the HDD to the “FRONT” USB port seems to at least improve my “disconnect” problem.

And the NAS is always accessible (Even with mediaplayer turned off).

So in your case only the Speed penalty (100 MBit LAN or WLAN) would count against it.

I have received response from TP link

My question was similar to the problem description here (earlier in this thread)

(It is in german but a summary here in english):

#Please excuse the long waiting time

#Maybe your problem is related to a HDD > 3GB.

#Our device can not do anything about his. The following happens:


# there is also a solution described which I would however not recommend.

=> my comment: Of course that is not my problem. My HDD is 1 TB only, and in my description I clearly stated that the drive is connected OK.

# I can assure you that the problem is not caused by the router but by the TV. The declaration as audiofile is a clear hint for the wrong Boottable.

=> my comment: This was the answer about the problem with streaming Router => mediaplayer. Any experience that a wrong “Boottable” of the mediaplayer may be the rootcause of detecting streamed video files from as audio?

# A router uses not workgroup. This is only used by PC. the router is outside of this workgroup.

# The three functions of USB, mediaserver, FTP and share are easily explained: Only the mediaserver is visible in the Network, the other two are only accessible as share folder, so only by its share address.


=> my comment: OK, that was the answer. No problem solved. As smart as before. :frowning: