WDTV doesn't find hard drive connected to router

Hey there!

I have a problem and wasn’t able to find a solution in the forums as of yet:

I have a hard drive, which is connected via USB to my router (TP-LINK Wireless Dual Band Gigabit Router WDR3600). From the router setup, i can share my hard drive and from my PC I then can access the hard drive via the router without any problems. However, my WDTV doesn’t see the hard drive.

My idea is to have the hard drive connected to the router and so I can watch my videos on this hard drive via the router using WDTV without having to switch on my PC. The workaround is to have my hard drive shared and connected to my PC, which does work, but then my PC has to run while watching…

Is there a solution for this problem? Any ideas would be appreciated :slight_smile:

Adaneth wrote:

Hey there!

 

I have a problem and wasn’t able to find a solution in the forums as of yet:

 

I have a hard drive, which is connected via USB to my router (TP-LINK Wireless Dual Band Gigabit Router WDR3600). From the router setup, i can share my hard drive and from my PC I then can access the hard drive via the router without any problems. However, my WDTV doesn’t see the hard drive.

 

My idea is to have the hard drive connected to the router and so I can watch my videos on this hard drive via the router using WDTV without having to switch on my PC. The workaround is to have my hard drive shared and connected to my PC, which does work, but then my PC has to run while watching…

 

Is there a solution for this problem? Any ideas would be appreciated :slight_smile:

Do the workgroup names match?

Actually I can’t find any entry in my router setup about a workgroup name. Do you have any idea where I could change that?

I was thinking about that too, but since I didn’t find a setting, I thought it wouldn’t matter.

@Tony,

The WD can see the shared drive on the router if the PC is on, but not if it is off.  This sounds like a master browser issue to me.  What do you think?

Look at your routers manual.  Where the settings is is different on each router, but is should be under either USB or Storage settings.

mike27oct wrote:

@Tony,

 

The WD can see the shared drive on the router if the PC is on, but not if it is off.  This sounds like a master browser issue to me.  What do you think?

I don’t think that’s what the OP said, he said that he can see the drive attached to his router from the PC, but not the SMP.  And he can access the drive via the SMP if it’s attached to the PC.

Interesting that the manual doesn’t have any info on it.  I can’t find it…

Well, I might be wrong, but looking at the manual it doesn’t look like it is capable of network shares, just http, ftp and media server.  That’s all I see being mentioned.

From pages 64 & 67

“Choose menu “USB Settings→Media Server”, you can create media server that allows you to share stored content with other computers and devices on your home network and on the Internet.”

“Storage Sharing users can use Internet Explorer to access files on the USB drive. FTP Server users can log into the FTP Server via FTP Client.”

There’s no mention of network share setup. If that’s the case then it wouldn’t have a workgroup setup.

I see it  Support Samba(Storage)/FTP Server/Media Server/Printer Server. You need to create users (Which you have done already). Can you see TP Link SSID name in Media Server in WDTV menu.

Make sure all devices/PC are in same workgroup.

Yes, I can see my hard drive as media server. I can also play some videos, but as far as I know it’s not possible to play .mkv files. I tried it and it doesn’t work. I don’t know the reason, but it seems that you can play those files only with network share. And there’s the problem, my WDTV doesn’t see the hard drive at network share, only my PC. When I connect the hard drive to the PC and share it, WDTV does see it, but yet again, my PC has to run.

Is it possible that the router doesn’t have this feature? Kinda hard to believe, because that’s what the USB inputs are for according to the description. To have hard drives or printers in the network…

Thanks for your input so far!

it should work. If you have SMB server on Router . I am using same way . I can see my HDD in WDTV in media server & Network share both.  My Router is linksys E3000.

@MKV - It depends upon Media Server . I can see MKV file also under media server menu which is atrtached to router . But not from Media server hosting on PC or other Media server in lan. 

can u send me Storage setting from rotuer page. 

As I said, I can see my HDD when it is connected with the router from my PC and other PCs. Only WDTV can’t find it and I honestly don’t know why… I guess it should be simple to just plug the HDD in my router, share it via the router setup and access it via WDTV. Well, unfortunately not…

OK, so here’s the settings from my router setup:

USB Settings

  -Storage Sharing (there I can see my HDD, the status is “Started” and “Shared”). So I’m guessing it’s correctly configured, since it is shared and I can access it from my PC and other PCs.

  -FTP Server (says “Stopped”)

  -Media Server (“Stopped” since I can’t play all the files. If I start it, I can play some, but no .mkv files. That’s why I want network share to work…)

  -Print Server (don’t need it)

  -User Accounts (there I have an admin and a guest account, both can read and write)

And that’s all under the header “USB Settings”.

Hope that helps :slight_smile:

try reset on wdtv .(I had strange issue- one port was not able to see 500 GB HDD while other could see)

On a Windows PC, issue the command

nbtstat -a ip.address.of.your.router

You should see output with something like this:

C:\Users\Tony> nbtstat -a 10.0.0.10

Local Area Connection:
Node IpAddress: [10.0.0.8] Scope Id: []

           NetBIOS Remote Machine Name Table

       Name Type Status
    ---------------------------------------------
    BIGNAS1 <00> UNIQUE Registered
    BIGNAS1 <03> UNIQUE Registered
    BIGNAS1 <20> UNIQUE Registered
    .. __MSBROWSE__.<01> GROUP Registered
    WORKGROUP <1D> UNIQUE Registered
    WORKGROUP <1E> GROUP Registered
    WORKGROUP <00> GROUP Registered

    MAC Address = 00-00-00-00-00-00

Please cut & paste the output here.

OK, sorry to sound stupid again, but where can I find the IP adress of my router? It should be the one under LAN, right? Which is 192.168.1.1

However with this IP i can’t get any results with this command… It just says host not found… I can put the IP adress of my WDTV in and then I get this:

Knoten-IP-Adresse: [192.168.1.110] Bereichskennung: []

      NetBIOS-Namentabelle des Remotecomputers

       Name               Typ          Status
    ---------------------------------------------
    WDTVLIVE       <00>  EINDEUTIG   Registriert
    WDTVLIVE       <03>  EINDEUTIG   Registriert
    WDTVLIVE       <20>  EINDEUTIG   Registriert
    :slight_smile::slight_smile:__MSBROWSE__​:slight_smile:<01>  GRUPPE      Registriert
    WORKGROUP      <1D>  EINDEUTIG   Registriert
    WORKGROUP      <1E>  GRUPPE      Registriert
    WORKGROUP      <00>  GRUPPE      Registriert

    MAC Adresse = 00-00-00-00-00-00

I’m sorry that it’s German and I’m not sure that it helps. Is there any other way I can help you getting the information you want?

if you have inbuilt modem + adsl in same - it will be 192.168.1.1 else 192.168.0.1. or how do u browse router page to start usb storage setting . that address is router’s ip address.

you can use google translater.

First, I have to ask the question:  Is this router your ONLY router?   Or are you using more than one?

If it is your ONLY router, then,  On the same PC, issue the command

ipconfig

You’ll see:

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix . : (hidden).net
   IPv4 Address. . . . . . . . . . . : 10.0.0.8
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 10.0.0.1

 The line in English says “Default Gateway” – 10.0.0.1

Don’t know what the German translation will be, but it will probably be the fourth line like mine.

The Default Gateway is your router.

If indeed the 192.168.1.1 address you tried is correct, then there is *something* wrong with your router, and that would explain why the WD won’t be able to find it.

OK, thanks again!

So the IP adress 192.168.1.1 is indeed the correct one. However with your command I don’t get results, as mentioned.

I get this:


 C:\Users\Matt>nbtstat -a 192.168.1.1

Ethernet:
Knoten-IP-Adresse: [0.0.0.0] Bereichskennung: []

    Host not found

WiFi:
Knoten-IP-Adresse: [192.168.1.110] Bereichskennung: []

    Host not found

LAN-Verbindung* 2:
Knoten-IP-Adresse: [0.0.0.0] Bereichskennung: []

    Host not found


Weird, other than that the Router works perfectly fine, I didn’t change any settings.

Alright, thanks for your help guys, I’m trying customer support of TP-Link, maybe they can help me out.

This shouldn’t matter, but try a “-A” instead of “-a”  (Capital A instead of small)

It does matter, little -a is for the machine/host name, the -A is for the Ip Address…  Technically speaking that is :-)  But it will work either way :-)    Also, lets not overlook the obvious here as well, does your router have firewall services running preventing the lookup, etc… ??