WDMyCloud & Windows 10 November update - Microsoft call!?!

#1

I attempted to get some answers from Microsoft today about the continuing problems of NAS devices now either slow of non-responsive. Here is a brief transcript of that chat:

Hi, thanks for visiting Answer Desk! I’m ****** B.
11:01 am
****** B
Hi there! Hope you are doing well today! How can I help you?
11:01 am
Me
Ever since the 10586.36 build of Windows 10 my NAS devices barely function - mostly not.
11:01 am
Me
In fact most networking activities are severely slowed down.
11:02 am
****** B
I’m sorry to hear that your NAS devices barely function , let me go ahead and find a way to fix this for you I understand how important it is for you to use our services. No worries, I am here to help you.
11:03 am
Me
Thanks
11:03 am
****** B
By the way, what NAS stands for? <<<<<<< I nearly fell off my chair!
11:04 am
Me
Network Attached Storage (it is a WDMyCloud 2TB network storage device).
11:04 am

===========================================
There was more but as you can see it was not looking like I would get any answers and I didn’t.

All 3 of my Windows 10 with November updates are unusable with my WDMyCloud. I will call Microsoft Tech Support on Monday and see if I can escalate this.

Paul

#2

What kind of problems are you having? Both my desktop and laptop have Windows 10 current update and I am not having any problems. Maybe I don’t use mine the same as you use yours. I mainly use mine for backup of both my computers and cell phone. For streaming, listening to music etc. I prefer doing it using my desktop since it has a better processor, quad core intel i5 3.00 GHz and I am sure is a lot faster than the My Cloud.

cat0w
USA

#3

I have a fairly normal setup on my LAN (mostly Gigabit devices) having a few computers, a tablet, an iPod, a WDMyCloud 2TB NAS plus several other multimedia devices like TV’s and BluRay players.

But more importantly, everything was running perfectly until the Windows 10 November update (1511 build 10586). As soon as that update was applied and the systems rebooted, things on the network started getting slow and the WDMyCloud basically disappeared. You could click on a network share and go for a coffee, stop for donuts and take a phone call before that share would show up in Windows Explorer! Sometimes it never shows up.

I am still fighting problems in some computers where the Windows Explorer simply stops working! Did you ever try to restart a Windows computer with a non-responsive Windows Explorer? Fun.

I know that not everyone with Windows 10 November update are experiencing problems and that leads me to believe it’s some device or configuration different to my setup - routers, AP’s etc. If you Google Windows 10 “Some protocols are missing” error message you will see that this is not an isolated problem; it is nearly epidemic.

Monday I call Microsoft tech Support. Fingers crossed.

Paul

#4

I should add that most of my network is wired; only the tablets, iPod and one ASUS netbook are wireless.

Paul

#5

[quote=“Morden2004, post:3, topic:144708, full:true”]
But more importantly, everything was running perfectly until the Windows 10 November update (1511 build 10586). [/quote]
Same here on one PC, the November Win 10 update started causing one particular issue with the My Cloud, it not showing up under Computer in Windows File Explorer. I can work around it as is, or I can modify the SMB settings in either Windows 10 or the My Cloud as indicated in the Compilation of Windows 10 Methods, Steps and Solutions, Method 6 entry.

Edit to add: If one does a Google search they’ll see others are having various issues with the Windows 10 November update. Including problems seeing other devices on the local network.

#6

Microsoft has a solution; in-place upgrade of Windows 10 - meaning reload the whole thing. Ugh. Having previously tried a system reset (several times), repair (several times), restore (several times) plus other repair procedures, non of which worked, I bit the bullet and did an in-place upgrade (reinstall).

Well of course it ran fine after the upgrade BUT you are now having to reinstall everything! Since this is my second time doing this in the past three days I am creating a Restore Point every 30 minutes. They are not going to catch me again with my recovery pants down. :scream:

So far the WDMyCloud can be successfully mapped and accessed even after a reboot. It still does not show up as a device under computers, but that isn’t serious. The ONLY modification necessary was to enable TCP-IP over NetBIOS for the network adapter.

More reports later.

Paul

#7

Doesn’t an in place upgrade of Win 10 wipe out all user data? If I remember right I think that’s what I did on one PC at one point for testing purposes and it wiped out all user data in the process.

For my one Win 10 test bed PC that is having trouble, setting the SMB2 to SMB1 worked at getting the My Cloud to be listed under Computer in Windows Explorer.

#8

Where is the computer in windows explorer? Are you talking about This PC?

RAC

#9

Select Network in WE

Paul

#10

No, it doesn’t wipe user data but you do lose any installed programs (unless you happen to install them on a different drive).

Paul

#11

I’m talking about Windows File Explorer in Windows 10. When I select Network in Windows File Explorer the My Cloud isn’t shown under Computer (in the right panel) but is shown under Media Devices and Storage. The My Cloud also isn’t listed under Network in the left column. On this Windows 10 PC I have Network set to “Private network” under Network and Sharing, and NetBIOS over TCP/IP is enabled under Network Connections, Network Adapter, Internet Protocol Version 4 (TCP/IPv4) - Advanced TCP/IP Settings.

Before SMB fix:

After SMB fix:

#12

I went back and looked at my notes. What I did in that instance for testing was upgrade from Windows 7 to Windows 10. Then did a “Restore factory settings”. This is the Windows 10 PC that is having the trouble showing the My Cloud in Windows File Explorer ever since the November update.

#13

This is my display. With out any fixes.

RAC
PS smb2

#14

I guess I should have pointed out that I never use [My Documents] & [My Pictures] etc. for that very reason; having lived long and hard with Windows since Ver: 3.0 and spending a lot of my working life as a Microsoft SE I have learned that you should always avoid those ‘convenience’ folders and categories for the simple reason they are always at risk when Windows screws up. I direct all my personal data and installed programs to personally created folders on a non system drive. Color me careful!

Paul

#15

The network is starting to exhibit shortness of breath! It is now slower connecting a share in WDMyCloud with Windows Explorer and programs are starting to wait for those folders to be populated. Only 8 hours since it was restored.

The only significant addition to the network since early this morning is my Dell color laser which is connected to the network. Can it be that?

Paul :rage:

10:30PM and we’re back to no response from network attached storage. It slowly degraded over the day. I may regress back to Windows 7 Pro.