WDMycloud doesn't recognize USB drive

I have two 4TB USB drives that I’ve been using for backups of my WDMycloud OS5. I reformatted one of them recently and the MyCloud no longer recognizes it. I plug it in, but nothing shows up on little USB device widget at the top. I’ve tried rebooting the MyCloud with and without the USB drive attached, and it still doesn’t recognize it. I formatted the drive as NTFS from my Windows 10 PC.
I’ve found a number of threads about this problem, most of which are several years old, but could not find anything that worked for me.

Any suggestions?

Hi,

My Cloud does not recognize an attached external USB device.

When an External USB device is attached to a My Cloud:

  • Will be viewable from the My Cloud Dashboard.
  • Non Password Protected USB Drive will mount as a Public Share which can be made Private .
  • Accessible in Windows File Explorer and macOS Finder as a network attached drive.
  • Remain password protected which can be unlocked or relocked from within the dashboard.
    The My Cloud will mount a Password Protected USB drive as a Private Share , which can be changed to a Public Share .

Please refer to this KB article for more information: External USB Drive Will Not Mount, Not Seen or Detected by a My Cloud