Wdidle3 not working on new BLUE drives ;-( Any help?

I had my WD40EZRZ drive for a week and it’s load cycle count is already well over 10,000. The drive is only rated for 300,000, which would mean around half a year.

All I could find so far is old information about the old Green drives, but nothing much about how the LoadCycleCount issue affects the Blue drives or how to fix it.

Basically my support was given a the brush off. The first answer I got was a link to a list of solutions outlining all the things I already tried and was zero help:

Thank you for contacting Western Digital Customer Service and Support.

We do apologize for the inconvenience.

Please see the link below for the WD internal hard drive that supports WDIDLE3.

The S.M.A.R.T Attribute 193 Load/Unload counter keeps increasing on a SATA 2 hard drive
https://support.wdc.com/knowledgebase/answer.aspx?ID=5357

If you have any further questions, please reply to this email and we will be happy to assist you further.

Sincerely,
Western Digital Service and Support
http://support.wdc.com

I responded with this:

Doing more googling reveals that hdparm -B 255 /dev/sdX does not work on WD drives unless you set wdidle3 to disabled. So now I am in a loop. The wdidle3 utility does not work so hdpram will not do what I need it to do.

So can you please provide a utility like wdidle3.exe that can disable the head parking on my drive?

Thank you,

I then got a follow up answer from WD:

Thanks for your reply.

The drive is set for a combination of reasons including power and reliability. Changing the drive, alters how the drive was manufacture and sent out to be used. I would then ask, can you let me know why you are wanting to change this , are you installing in a PC, mobile (if 2.5"), RAID, or industrial application. is the drive going to the ramp to often\to quick or is it not quick enough ?

WD strives to exceed customer’s expectations. If you feel that your expectations have not been met and would like to escalate your case to the next level of support, please click here or copy and paste the link below in your browser.

http://support.wdc.com/support/caseEscalate.aspx?sfacc=0010P00001nqGuv&sfcase=5000P00000YygXk&lang=en

Sincerely,
Western Digital Service and Support
http://support.wdc.com

From this I can take a hint. WD no longer wants its customers to be able to change the parking timer on their drives and they do not intend to allow us to alter it anymore. I suspect that WD wants to force customers to buy RED drives with longer idle parking times. Because of this, I returned the WD drives and bought another brand.

IMHO this is most likely a corporate decision and there is little hope of getting an answer that is satisfactory.

craigr

This isn’t good. Guess I am going back to SEAGATE. Obviously Western Digital has gotton soo big that they do not care about their customers data. really sad. :frowning:

Also, which brand did you replace it with. I did get segate and their software for head parking works (hdat2iso_50.exe)

These drives are designed as intended, and you should have no issues with the parking counts. We are not trying to force customers to Red drives, since they are not intended for typical desktop applications.

You should take the offer to escalate your case so that support can more closely look at what you’re using the drive for, and why you think you need to change the parking time.

Oh, and just so you all know, WDIDLE3 is an obsolete program that only worked with specific model drives. This is likely why some of you are getting errors when trying to use it.

Hi
I have the same problem, but I couldn’t return back this drive (unfortunately). I’m using it as the drive in my desktop, not for dedicated file storage. I found two solutions for me, they are controversial probably:

  1. Start very the very small script like, this is kind of pseudocode:
    start: echo “.” > :\nopark - create the file on target disk, the name can be any
    del /y :\nopark - delete created file.
    sleep(5) - sleep for 5 seconds
    goto start
    Tested for Windows only, but I think it also works for Linux also, but you have to change the commands. This script can be started from task scheduler as action of system booting and it won’t be shown at task bar. Also it doesn’t make any notable performance impact. One thing I didn’t like in this approach - when environment is very quiet (at night for example) you can hear some periodical activities from the drive
  2. The another approach I’m using now - start the SMART full test for the drive. For my 4TB EZRZ drive it’s working 14 hours, and heads are not being perked during this time. I did the very small script (like previous) to start when system boots and then just restart the SMART testing. I also tested performance on this drive and didn’t find any notable impact. You can use any third-party utils to start SMART tests, I can put details if anybody is interested.

Well the reason he wants to change or disable this aggressive parking of the heads is to reduce the amount of wear and tear this creates. A lot of users have these drives running 24/7 in computers or NAS boxes and the Load Cycle Count racks up in no time.

if someone can return such blue drives - it’s a preferred way. But I couldn’t, so I suggested the two approaches to stop excessive parking of heads. Not sure about NAS systems, but I highly suspect there is way to do the same thing thru OS installed on board.

Any news on that ? I would really like to be able to change the parking timer… this is creating useless wear and tear on the drives…

Also Alex_Osh, would you mind describing how you did it through windows ?

Bill you are an ignoramus and clearly are not qualified to answer questions in spite of the fact that you are affiliated with WD. Any simple google search will reveal the fallaciousness of this statement. I can also personally testify that wdisle3 worked on all WD drives until recently.

You are simply a WD stooge uninterested in actually helping.

Good bye WD. I don’t buy your drives anymore because if this.

At least we can RMA them when they die after 6 months, sell them and buy HGST

Except you will have to pay for shipping to the RMA facility, as I learned the hard way. If WD doesn’t want to issue prepaid labels, then they should at least refund the shipping label cost once an error is confirmed.

I bought two new drives WD40EZRZ-00GXCB0 and put them in a Windows Server 2016 24x7 machine. In 11 days the drive parked 13955 times or 1306 parks/day. So this time around to get to the magic 300,000 cycles will require only 229 days. So the life of the drive is less than a year?

And yes I’ve raised a ticket with WD …

Hi: jgalea

See Craig_Rounds solution at

NotaCanada

WD’s reply for my drives is: “Unfortunately, Intellipark feature or idle time settings for the hard drive cannot be changed, this feature is used to safely park the mount head when there is no read/write operation to secure data stored on platters from damage.” But no mention on what the life of the drive on this parameter is.

Since I haven’t read this forum a long time, I’m not sure if somebody is being interested, but here are the info I have:

  1. If you have just regular drive in you system (let say disk F:)- you can create .bat file:

    :start
    echo . > f:\file.dat
    timeout 6
    goto start

Then start this task in windows scheduler, it will not show console window, so it will just work
This is simplest method
2. Also, as I found out, when you started extended smart test on you drive it wont park its heads for whole time of the test which is around 10 hours (as I recall). Al we need to do the same approach as at I said at first case, but .bat file will be as follows:

:start
D:\Sys\smartmontools\bin\smartctl.exe -X /dev/hdc 
D:\Sys\smartmontools\bin\smartctl.exe -t offline /dev/hdc
timeout 36000
goto start

A few notes: this is the WINDOWS version of tool, but it needs Linux-style of your device drive identifier.

Although I’m “IT guy” I’m not really aware of HDD internals, this is very specific area. All I found out - just two methods to tackle the problem. As I tested - both methods work and they don’t make any noticable performance impact of the drive. If I could return my blue drive I would do it instead of digging forums and making such pathetic crutches :slight_smile:

As of today - the drive still works without any problems or errors, so - you decide. Please see attached screen shot of hddscan . Also you can start extended smart test by the hddscan (http://hddscan.com) tool and check load/unload count after then.

Thank you for sharing.
I made a preventLCC.sh script that I use on a Ubuntu machine.

#!/bin/bash
FILE=/data/preventLCC.tmp
USER=rimidalv

while true
do
        /bin/echo "Temp file to prevent LCC. This file is overwritten every 4 seconds" > $FILE
        /usr/sbin/smartctl -a /dev/sda | grep Load_Cycle_Count >> $FILE
        /bin/chown $USER:$USER $FILE
        /bin/bash -c '/bin/dd if=/dev/sda of=/dev/null count=1 skip=${RANDOM}' >/dev/null 2>&1
        /bin/bash -c '/bin/echo ${RANDOM}' >> $FILE
        /bin/sleep 4
done

You call it in a root crontab like this.

sudo su
crontab -e

Add

@reboot /data/preventLCC.sh

Does it work? As I recall, it may need to create/delete the file.
I highly suspect if we just read SMART info - drive wont park its heads. I tried this by clicking the “Smart” button on HDDScan tool - it shows regular SMART registers, but seems reset parking rimeout at the same time.