WDH1CS5000N My Book Home Edition won't mount on 2016 MacBook Pro

Hi all, I am hoping someone can help! I recently purchased a new 15" MacBook Pro with TouchBar. Upgraded from a 2008 MacBook Pro which was showing it’s age! In trying to hook up my old WD My Book Home Edition external drive (that I have been using for the past 7 years to back up data on my old 2008 laptop via Time Machine) to my new MacBook Pro via USB (using an Apple USB-C Digital AV Multiport Adapter), the external hard is not mounting. Opening up Disk Utility confirms that the computer is not recognizing the drive. The Drive itself powers up, spins, and the external lights turn on but other than that…nothing.

I took everything to the Apple Store for help. They attempted to connect the hard drive to my MacBook Pro via Firewire using a daisy-chained USC C to Thunderbolt Adapter/Thunderbolt to Firewire 800 Adapter set up. Same result: the hard drive powered on, spun with the external lights on but it did not mount. They tried hooking up the hard drive to a MacBook Air via the Thunderbolt to Firewire adapter and it also did not mount so the Genius concluded it must be a hardware problem.

I find this puzzling though because the hard drive was working just fine on my old 2008 MacBook Pro as recently as 3 days ago. Unfortunately, I no longer have my old MacBook so I can’t do a computer to computer data migration.

I have over a decade of sentimental files and documents on my external WD hard drive so any suggestions short of sending it out to a data recovery service would be greatly appreciated. Thank you in advance!


I believe (based on past experiences) the issue could be related to the adapter. Have you tried using it without the adapter?

I believe this drive supports USB 2.0 , FireWire400 and eSATA

Hi Hamlet,

Thanks for your response! If the adapter is the issue, it would appear the only way for me to plug the drive directly to the MacBook Pro would be to find a USB-C to USB mini cable. A quick Google search shows that Belkin makes such a cable so I guess I will order it and hope for the best. I will post an update shortly afterwards…thanks again!

It worked! I ordered a Belkin USB-C to USB mini cable and at first upon plugging it in, the drive didn’t mount but I did some combination of shutting down my MacBook Pro and unplugging everything and reattaching all the cables and powering back on the laptop and the WD drive finally mounted! Using Data Migration, all my files, documents and applications were restored within 90 minutes! Thanks so much! You saved me from having to go to a data recovery specialist and potentially dropping $$$$!!