WDCloud Hangs

#1

Windows 10, WDMYCloud, two computers on Ethernet and WiFi. No idea what firmware I’m running because the browser just flippin hangs and wastes so many hours of my time!!! (I’m angry and frustrated)!

I have installed WD Sync and WD Access, on both computers.

When clicking on “Network” in Windows Explorer, I can see all computers and printers in the “Computer” section.
The WDMyCloud is visible in Media Devices, Storage (on both computers), but on the wifi laptop, I cannot see it in the “Computers” section. but I can see it on the ethernet desktop.

Right clicking the tray icon in both computers / WD Access / WDMyCloud / Map, I can see all the shares on the cloud.

I can see the shares no matter what computer I’m on if I enter “\WDMYCloud” into windows explorer.

When I do get to see the shares on the desktop (not seen them for a while on the laptop as it hasn’t worked), it asks me for my network credentials!? I have no idea what needs putting in here! I’ve tried my WDCloud user login (\WDMyCloud\Pete with password of blank) but it doesn’t like it.

Right click the tray icon in both computers:

  • WDAccess / MyCloud / Settings
    Opens the web browser to the admin login. I click login and just hangs and hangs and hangs and hangs… for 15+ minutes, usually with no joy of fully loading the next page of the dashboard.

  • WDSync / Configure
    On both computers sees the spinning wheel just spinning and spinning and spinning and…

I have both computers configured as per this post, but no joy.

I’ve tried 4 second reboot, 40 second reboot, not size 8 reboot out of the study window as yet though. This is stopping me setting up me new computer, which in turn is stopping me working on my project. WDMyCloud has never been very reliable though I must say. Always very hit and miss whether I can connect or not.

Any more thoughts PLEEEEEEASE!?

#2

I notice that another wireless computer (Surface Pro), has the same issues with seeing WDMyCloud as a computer in Network.

The WDMyCloud is visible in Media Devices, Storage (on THREE computers), but on the wifi laptop and the Surface Pro, I cannot see it in the “Computers” section. but I can see it on the ethernet desktop.

I have a BTHub6 if that helps?

#3

A couple of things here: Most of the frustration with ‘seeing’ the WDMyCloud is a Windows 10 quirk. So, the best way to attach your WDMyCloud to your Win 10 system(s) is to MAP the WDMyCloud.

In Windows Explorer, select the [Computer] tab and click Map network drive (from the drop down). Enter the network name of your WDMyCloud (hopefully you left it as default [WDMyCloud] in the Device Name of the Settings/General tab) in the Folder Name of the Map box. Click finish. Hopefully this will work.

Try that first. Also, you should ensure that your Windows network Workgroup name is entered into the WDMyCloud Settings/Network/Network Workgroup.

Paul

#4

First, if you haven’t done so already read the My Cloud User Manual (https://support.wdc.com/product.aspx?ID=904). The User Manual explains how to use the various features/options of the My Cloud including creating Users and Shares. Typically if Windows prompts a user for a Username and Password when accessing a Share on the My Cloud one would use the user name and password created through the My Cloud Dashboard. If you do not know how to access the My Cloud Dashboard, see the following WD Knowledgebase article.

If the WiFi devices cannot access the My Cloud check to ensure the My Cloud and WiFi devices are using the same workgroup name and are using the same IP address range (ex. 192.168.1.x). Then check the administration page for the WiFi router to ensure it doesn’t have the option to isolate the WiFi from the wired network, or that WiFi devices are using a “guest” network which may be isolated from the wired network. Also look in the router administration screens for “IP isolation” or a similar feature which may be preventing WiFi devices from seeing the rest of the network.

Also, in certain cases the computer firewall may be blocking access to the local network and in the case of accessing the My Cloud Dashboard or MyCloud.com web portal, browser add-on’s/extensions may be blocking or interfering with access to the My Cloud Dashboard and MyCloud.com web portal.