WDcloud_EX2 after full system restore - fail to access

I using WDcloud for some time (almost a decade!), on a Windows, Mac, and Linux machines. All worked OK.

After a full system restore, I can reach web page (dashboard), since it has a static IP, but both on Mac, and Windows I can’t actually connect to it.

On Windows I see it under “Storage”, but is not identify under “Networks”.
On Mac, I try to connect, but connection fails ( using “connect to server”).

Firmware is at its latest version.

What might have append?

Do you mean you can get to the login page but can’t log in? What do you see when you “reach” the login page

Sorry for not explaining right.
Connecting to NAS via its web site (dashboard) - is OK for all platforms.

Windows & Mac machine can not connect/ Map a share, as if something is not defined as needed.
Since nothing was changed (same cables, PCs, LAN, router) before restore, I’m sure it has to do with NAS’s properties

OK, so you can access the dashboard but not the files. Check the network settings on the NAS dashboard/menu. In windows, if you can see it at the bottom of the page under “storage”, that gets you to the dashboard. If it’s not at the top of the page, under “computer” then that’s why you can’t access the files. Is the “Public” folder shared? Go to “Shares” on the dashboard and make sure “Public” and “Media Serving” are turned on. Have you tried setting the NAS up as DHCP? SNMP to “all”?

it is placed there and clicking on it, takes to dashboard as expected.

yes it is shared, and also 'Media ServingisON`

NAS is DHCP, and SNMP was “OFF” but changing it to “All” didn’t changed a thing.


So it’s not static, its DHCP?

It is static, but I confige its IP via the router ( he is the man in charge :slight_smile: anyway )


We have reached out to you via direct message, so we request you kindly check and reply to your DMs so that we can assist you further.