Wdc blue 1tb hard drive giving me a semaphore error

Hello I bought this hard drive around 2 or 3 months ago but barely used it maybe filled 100-200gbs, While I was storing files into it, it stopped transferring and stalled and then gave me the warning “The semaphore timeout period has expired”. I tried to restart my computer and it usually takes around 5secs because I have a SSD but this time around after the error it took me around 15mins to just boot up. After I couldn’t get in to my computer, windows tried to repair it self and when it restarted it self my computer automatically disabled the WDC blue 1tb storage drive and wouldn’t let me reinitialize it, and when I try to it gave me another semaphore error. With the hard drive disabled my computer run completely smoothly and everything boots up as normal so I tried to move the hard drive to another computer and gave me the same error. Does this mean my the hard is completely dead? I cannot even initialize it to check its health and I’ve looked on the forums to look for similar problems and I cannot find any that are like mine any help would be greatly appreciated!

Hi,

If possible test the unit using the WD DLG tool to see if you are getting a sector issue on the drive.

Link to WD App: http://support.wdc.com/KnowledgeBase/answer.aspx?ID=940

Also see if the following link helps:
http://answers.microsoft.com/en-us/windows/forum/windows_vista-files/error-0x80070079-the-semaphore-timeout-period-has/6cd88126-6bc5-460e-80f6-1bcaa017e422