wd500bpvt dead?

Hi all,

I have WD Elements Portable which stoped working. I opened it and removed usb connector. Now I have WD500BPVT in my hands. I attached it to my PC via USB-SATA device, but it’s not detected by windows. I can hear/feel that device hd powers up and disk’s are spinning.

I have read many of posts, but not sure what to do. Is PCB fried or any ideas how to get it up and running?

EDIT: image of PCB


Just to add,

I don’t the reason why my device stopped working. I havenät dropped it or anythin. Only reason I can image is that it was used in very warm and high humidity environment when it failed (i was @ vacation in Thailand)

Anyone, plz help me?

Additional info, if i use my wd500pbvt with original usb connector (if that’s what it is called), white led on it blinks very fast.

When you connected the drive to the computer, did you check if it was recognized on the disk management?


Thanks for you reply,

no it wasn’t recognized by Disk Management, LifeGuard or HDDScan.

Just to add, also os x disk utility does not recognize my drive

Can you see the “USB-SATA device” in Device Manager?

How does Microsoft’s UVCView utility see the external drive?

Can you connect the drive directly to a SATA port on your motherboard?

OK, now for some reason i can see my device in device management as USB drive, on UVCView can see device. But I cannot access it as it not listed as drive in My Computer. I’ll have to try connecting directly on SATA ports (hard job, as I have to clean my desk first=)

It appears that Windows is detecting the USB-SATA bridge board/IC inside the enclosure, but it is unable to see the drive behind the bridge.


thats what I thought too. In Disk Management i can see it as Disk 2 and windows says it’s uninitialized. When I tried with Ubuntu Recovery Mix, I can see it as /dev/sdb, but it does not have partitions. Slowly my faith is fading to get my data back, or can you guys help?

A direct connection to a SATA port will confirm whether the HDD is at fault, or the bridge board. That said, since HDDScan can’t see the drive, and since the drive is spinning, then the bridge board is most likely OK.

OK, connected directly to my laptops SATA connector. And tried to access HD via Live CD’s, but none of them can regonize HD

I don’t understand why Disk Management and Ubuntu can see *something* but HDDScan can see nothing. A detection issue is often the result of damage to one or more firmware modules in the System Area on the platters. When this happens, the drive will sometimes report a capacity of 0 LBAs, or it may identify itself with a factory alias (eg ROM MODEL HAWK), or a strange serial number.

I’m really lost here too. To clarify my results here are some images:
Device Manager: https://dl.dropbox.com/u/14906492/device_manager.png

HDDScan: https://dl.dropbox.com/u/14906492/hddscan.png
TestDisk: https://dl.dropbox.com/u/14906492/test_disk.png

Do you think only solutions is to send drive to some professional data recovery company, or is there anything I could myself?