WD5003ABYX and 3ware9550SX-4LP

At first I tried WD5003ABYX and started to get a lot of SMART errors, and then I tried another WD5003ABYX and same thing both drives did not work with the 3ware9550 raid controller, did not work as raid or standalone drive.

Massive amount of time outs, and times the disks can not be seen and a reboot is needed.

The current drives that I am using with the  3ware9550SX is a seagate ST3500630AS  which works fine in raid 1, a few  ST3500630AS have died over time.

The strange thing is that I tested one  WD5003ABYX  on another computer as a single drive using spinrite 6, and tufftest and the drive tested with no errors, that same drive using the 3ware9550SX I get a lot of timeouts and Raw_Read_Error_Rate and smart tests fail.

Right now I am using Linux kernel and Centos 5.5

The only difference between the seagata and the wd, is that the Seagate uses ATA version 7 and the WD uses ata version 8.

Things I have been thinking of doing:

Compiling a newer kernel, maybe a 3.x so that I get newer sata drivers for the 3ware controler. 

Any recomendations or suggestions on what can be causing this very strange problem.

The firmware on the WD disk is   01.01S02

Is there newer firmware for the  WD5003ABYX disks and where can it be downloaded it from?

 Has anyone used succesfully a 3ware9550 raid 1 with  WD RE4 disks?

Did you check the raid controller compatibility list?

You may contact 3Ware and confirm if the WD5003ABYX is compatible with your controller. To verify if there is a firmware upgrade available you can contact WD Support.

I checked the disk compatability list at WD and the 3ware 9550 was supposed to work with the RE4 disk.

However when I asked LSI at first they said any enterprise raid disk should work with the 3ware controller, but once I reported the problem they said it was not on their list of supported drives for 3ware 9950, the problem with the list was that no modern hard  drives were on the list, so I purchased some rufurbished enterprise seagates, since the drives supported by lsi for 9550 were old drives and could not be found new at any place, the WD on the list were RE2, not even the RE3 was on the list.

The seagates NS were a disaster, they passed the smart tests, and even passed the controller 9550 drive verification test and seemed to be working fine, but during a raid rebuild the entire raid array crashed.

So I have decided to stop using the 3ware 9550 controller, and since the slot for the controller is PCI-X, I will use a silicon image 3124 disk controller card, the cards has 2 modes of operation fake raid, and as a SATA2 card, I plan on using it as a SATA2 card, and mybe use Linux software RAID 1.

I have not tested the RE4 disks with silicon image 3124 card, but I did test a blue caviar WD and it works fine.

I think RE4 disks should work fine with silicon image 3124, I will give that a try.

One leason I learned is that mixing hard drives in a hardware raid it is a bad idea, the problem happens when the hards drives being used are no longer available for sale.

I did have a backup, so I am safe.

The 3ware9550 was tested with 2 WD RE4 disks and both failed with massive timeouts, so clearly it was most likely a problem with the firmware of the 3ware9550 controller.