WD40EFRX never get into standby - firmware upgrade?

Hi all,

I have 2 PR2100 NAS which runs two different HDD
NAS1 - HGST ultrastar
NAS2 - WD Red 4TB - WD40EFRX-68N32N0

NAS1 works perfect
NAS2 goes into standby mode but every 20 minutes it’s spin the HDD for 1 minute and then it goes to sleep again.
of course I’ve tried to replace between NAS1 and NAS2 HDDs, I’ve format them and even restored default the NAS itself because I thought there is some issue with the PR2100

then I tried Seagate HDD that I have - and it works as expected. it goes into standby mode.
it’s only the WD RED that never “sleep” - even when the drive is completely empty

I spoke with WD support for months and they couldn’t really be helpful except telling me to RMA the HDD which I did twice.
in fact, I have 4 WD RED 4TB (WD40EFRX) that I purchased from different time (2017, 2019)

My current firmware is: 82.00A82

Did anyone experience the same or different?
Any ideas of what I can do? I really don’t like the fact that HDD spin every 20 minutes necessarily

Thanks in advance.