WD4001FAEX reported as 1677.90 GB in Windows Disk Manager after breaking apart RAID


I had 4xWD 4TB drives arranged in two RAID 0 raids.  I wanted to reset one of the RAIDS to non-raid while also doing a clean installation - my operating system is on a single SSD drive separate to the above raids.

I tried doing both resetting to non-raid and deleting the raid in the BIOS.  The BIOS does correctly detect the drives as 4TB.  No matter what I do in Windows, the drive is always detected as having a capacity of 1677.90GB.  I’ve also run the WD Lifeguard Diagnostics which also correctly reports the drive size as 4001GB.

I have also tried the write-zeros operation choosing the quick option which writes to the first and last parts of the drive.  This was unsuccessful in correcting the drive size reported to windows.

I am currently running the complete write-zeros operation for the whole disk which it reports is going to take about 7 hours.

Is there not a quicker way of having Windows detect the correct drive size?  I am happy to do a complete reinstall of Windows 7 (64 bit).  Install Windows 8.  Put the drive onto a different SATA port or even run around in circles with my hands up in the air :slight_smile: if it gets the job done quicker.

Please help!



I’ve since run the write zeros to the whole drive - it took about 7 hours.   Drive is still detected as having a capacity of 1677.90GB within Windows.

Absolutely astonnishing how difficult this is proving to resolve.   


Have you tried formatting the drive as GPT?

RAID mode and AHCI mode use different drivers. It appears that your AHCI driver has a 32-bit LBA limitation.