WD3200KS Hard Drive I/O Failure Please Help


#1

My Western Digital 320GB hard drive model WD3200KS seems to have failed, and I could use some help.   It was working fine, now all of a sudden it doesn’t show up in “My Computer”

1.  The hard drive spent it’s life in an external USB enclosure. 

2.  The hard is no longer recognized in “My Computer”

3.  Model is shown in Device Manager under disk drives

4.   Disk Management shows the drive, but says it requires Initialization.

I know it’s not the enclosure because I also tried the HD connected directly to the mobo and same result.

I tried a lot of the recovery software outthere but none seems useful because I can’t get past “I/O error” or “Sector 0 bad”

It sounds like the drive is spinning but I can’t be sure.  Any help would be greatly appreciated.

Many thanks,

Detox


#2

Hello,

I/O = Input Output error, you need to check all the USB ports, the cable and finally the enclosure. Since you already check the enclosure then your internal unit could be defective and you might need to replace it.


#3

Thanks for the response.

I tried the hard  drive connected directly to the motheboard using the SATA connection.  I did not use USB and get the same error.

Is there anything I can do to at least see the directory names on this drive so I can determine if I what to do with it.  I am worried there are some important photos/documents but can’t remember. 

Any help would be greatly appreciated.