WD20EARS not detected by BIOS. HDD working?

Hello,

I just bought a WD20EARS hard drive and it seems not working… It’s not detected either by BIOS nor Vista.

So I’ve tried to start my computer, hanging the hard drive in my hand : it “snores” for about 5 seconds then seems to stop.

Is there something to try or do I have to replace it ? 

Thanks for a help !

To which mainboard / sata controller is the drive connected?

Check the bios for correct sata configuration.

The disk may be dead  -> replace.

But if it not dead, it may not be recognized by the controller, in this case:

Check how the drive is jumpered:

The default is
 * 3-4 (no-jumper)
 * 5-6 (no-jumper)

Jumpers 3-4  —>  PM2 (Power Management 2) ENABLE (only for some disks)
Jumpers 5-6  —>  OPT1 is ENABLED (1.5Gb/s speed)

You can enable 5-6 to see if the drive is recognized by the controller at
this speed.

Check the bios for correct sata configuration.

The drive is connected to a Foxconn mainboard (sorry i don’t know which model).

About the bios, what have I to check ? I tried  the three sata config (IDE-RAID-AHCI) without any success. I also tried to plug the drive on other sata connectors but nothing better. However my other HDD is recognized by the bios.

By default the drive is not jumpered, but i tried jumper 5-6 (as shown in wd support website) as i think my motherboard does only accept sata I (I bought my computer in 2009). I also tried jumper 3-4, because i had nothing else to do… !

But no results.

What I’m worry about is that 5 seconds after I start my computer the drive stop working (no scratch, no noise, nothing).

Maybe a power problem… ? don’t know 

See my recent post on Caviar Green - your SATA connector may not be enabled in BIOS - found something that worked for me

I connected a WD20EARS to a K8M8MS motherboard and had similar problems. Not sure who makes the motherboard, I think it’s a Foxconn but Google suggests it’s a Jetway. I had to do two things to get the drive to work with this old MB. 1. Jumper the drive to force it to be SATA I. (See http://www.wdc.com/en/library/eide/2579-001037.pdf)) The BIOS could see the drive and I could format and install Fedora 14 from a Live CD at this point but it would always hang when I tried to boot the freshly installed OS. 2. Disable IDE HDD Block Mode in the BIOS (Yes, I know this is a SATA drive). (See http://www.techarp.com/showfreebog.aspx?lang=0&bogno=97 for a description of IDE HDD Block Mode.) This stopped the freezing at boot. My guess is that the BIOS doesn’t do a very good job of guessing how much data to read/write from these newer drives. It may make this machine very slow, I’ve yet to test it ‘in anger’, so this may not be a workable solution but I’m one step further on.