WD20EARS Cavair Green Internal Storage Freezes WIndows Boot, lost partitions


#1

I bought a Western Digital 2 TB Caviar Green SATA Intellipower 64 MB Cache Bulk/OEM Desktop Hard Drive WD20EARS  from Amazon a few months back. I installed it as a second internal drive for data storage for my PC desktop.

I partitioned it as one 500GB partition and one 1.5TB partition. It worked great for a month or so.

Then one day windows would not boot, it would freeze at the windows loading screen. After doing some researchonline I opened my computer and unplugged the 2TB CavairGreen and turned the computer back on. It booted fine. Ishut the system down again and re-plugged the 2TB CavairGreen back in. It froze on the Windows loading screen again. I read some more stuff online about jumper settings, so I shut down, removed the jumpers and then powered on.Windows started normally this time.

Now, Windows recognized the drive (only in Disk Manager), but not in Windows Explorer. The drive is now shown asaprox 1.8 TB of unallocated space.

I am afraid that if I re-allocate, I will lose everything and I do not want to gamble with file recovery programs…or shell outthousands for a recovery company.

I checked the BIOS and the boot order and all that is fine.

Ran chkdsk and after  few hours, Windows booted to the log on, but would not let me click anything to log on.

This drive has freelance files, family photos and videos. I feel sick. Any help?

Any thoughts on EASEUS Partition Recovery or any other programs tat might fix my issue?!

Thanks

J

I bought a Western Digital 2 TB Caviar Green SATA Intellipower 64 MB Cache Bulk/OEM Desktop Hard Drive WD20EARS  from Amazon a few months back. I installed it as a second internal drive for data storage for my PCdesktop.I partitioned it as one 500GB partition and one 1.5TB partition. It worked great for a month or so.Then one day windows would not boot, it would freeze at the windows loading screen. After doing some researchonline I opened my computer and unplugged the 2TB CavairGreen and turned the computer back on. It booted fine. Ishut the system down again and re-plugged the 2TB CavairGreen back in. It froze on the Windows loading screenagain.I read some more stuff online about jumper settings, so I shut down, removed the jumpers and then powered on.Windows started normally this time.Now, Windows recognized the drive (only in Disk Manager), but not in Windows Explorer. The drive is now shown asaprox 1.8 TB of unallocated space.I am afraid that if I re-allocate, I will lose everything and I do not want to gamble with file recovery programs…or shell outthousands for a recovery company.I checked the BIOS and the boot order and all that is fine.Ran chkdsk and after  few hours, Windows booted to the log on, but would not let me click anything to log on.
This drive has freelance files, family photos and videos. I feel sick. Any help?Any thoughts on EASEUS Partition Recovery or any other programs tat might fix my issue?!ThanksJ


#2

anyone?

:neutral_face: