WD20EARS Causing Windows to not boot

I’ve been running a WD20EARS in my 64 windows 7 box as a storage drive (not boot). Today I rebooted the machine and it stopped at the windows flag during boot up. If I remove the WD drive it boots fine I’ve tried different ports, sata cables and and even tested another drive on the same ports and power cables and it’s definitely this particular drive keeping windows from booting. I tried downloading the diagnostic CD for Dos and it boots and sees the Drive but says it’s not supported when I try to select it. I double checked and I definitely downloaded the correct diagnostic CD. Is the drive shot? Is there any troubleshooting I can try before I get an RMA? There’s a lot of data on this drive I don’t want to lose, but I’m stumped and don’t know what to try next.


As personal experience I install the drive into a external enclosure and remove all the data from it. After I complete the process the unit was formatted and installed again, it work perfectly.

The drive is not readable by multiple computers or in an external enclosure. I got an RMA and sent it in, is there any chance WD will repair the drive I send in or do they always send a different drive. As a long time WD customer with this drive being the first I had to RMA back I have to say that I was absolutely shocked, angered and dissapointed that I had to pay return shipping for the drive. As long as this is how WD is doing business I won’t be buying anything from them.