WD15EARS format problem using ubuntu

I can’t seem to format my internal 1.5 TB SATA drive using ubuntu 11.04 or 10.04…has any one done this successfully?

Hi there, what have you tried so far?

I have the same problem, I tried various combinations of things I found here and elsewhere but so far nothing seems to work. The best I can do is create a label and partition with fdisk, but when I try to re-read the partition it says the partition table is corrupt. Parted warns me about the write error immediately. Very confusing so far… For me the issue could also be the hardware: so far I tried a cheap USB enclosure and the onboard SATA of my rather old desktop (ASUS mb with socket 478). Also the disk makes a weird noise, like it’s spinning up then down continually, which could be related to intellipark…

I’ll post the solution here if I find one, but I have to say I’m extremely disappointed by WD philosophy vs. Linux users.

“All other OS: the disk can be used as is” says the label. It simply is not true. They must have figured otu that some geek will solve the issue for them at some point, and make it available for free, so why bother?

This is my last WD.

1 Like

What tool are you using?

For creating MBR partitions use: gparted (GUI), parted, cfdisk, or just fdisk (but it that case, remember to align the partitions).

For creating GTP partitions use: gparted (GUI), parted, gdisk.

gparted is probabbly the most ‘easy tool’. (sadly i do not use it and use bare fdisk/gdisk).

I do have a WD20EARS and it works ok with Fedora.

Since you did not post anything i cannot help you. Post whatever error you might have encoutered, otherwise there is no way to kwnow if you have a hardware problem or a software problem (fixable).

funny comics I admit.

I do not complain about the lack of support, but about the misleading message.

They say it’s ready to use as is for other OSs, which is not true.

I’d have preferred something more sincere like: “Other operating systems: figure it out.”

Update: given the clanky sound it seems more likely that the unit I got was defective.

To be sure I tried to install it in a very recent desktop with Windows 7, still no success.

The BIOS sees that there’s a new disk, but Windows doesn’t

BTW it seems it is possible indeed to use these disks under Linux, see here

The sector size problem applies to all drives using 4K sectors and only Win7 will currently align the partition boundaries properly. E.g. WinXP will fail as well with the standard jumper settings. I.e. no matter which OS (Win / Linux / MacOS, …) you’re using, you have to ensure that your partitions are aligned properly and unfortunately lots of partitioning tools still don’t do that automatically. One special problem about the WD15EARS however is (at least I do have that problem): it reports a sector size of 512 bytes where it should return 4096

TechGuy wrote:
 One special problem about the WD15EARS however is (at least I do have that problem): it reports a sector size of 512 bytes where it should return 4096

That’s not a “special problem”… that’s what makes it an Advanced Format drive.

If the drive really did just use 4096-native physical sectors, you would not be able to use it under ANY version of Windows, according to Microsoft.  They say _ none _ of their OSes support 4096-native drives.

That is exactly why WD has to “emulate” 512-byte sectors on their 4096  drives (which is what “Advanced Format” means).  Until Microsoft adds support for 4096-native, I’d highly doubt that WD would ever stop with the AF 512-emulation for their desktop drives, because then _ none _ of their drives could be used in _ any _ Wintel box.

I’m sure the *nix world wouldn’t really mind WD selling *nix-only drives, that won’t work in Windows, but it doesn’t seem to be a wise business choice from WD’s point of view.

Sorry, I wasn’t precise enough regarding the sector size. Advanced format drives should return a physical sector size of 4096, no matter if they return a logical sector size of 512 or 4096. I.e. 512e drives shouldn’t behave like Legacy 512 Native devices otherwise no OS will have any chance to know if the drive internally operates with 4k sectors (except for having an internal list of all drives which do have 4k sectors).

Technically spoken it should behave properly according to the ATA8 specification ( http://hddguru.com/download/documentation/ATA-ATAPI-standard-8/d1699r2b-ATA8-Command-Set.pdf) and return the real physical sector size for the identify command. This is supported since Win Vista: http://support.microsoft.com/kb/2510009/en-us

You’re right that no OS currently supports 4k native drives, i.e. drives that report and operate with a logical and physical sector size of 4K. But I was talking about the 512e / Advanced Format drives not the 4k native ones.

I found another discussion about all this here (even though it is about Linux in special):


I have been using WD15EADS and WD15EARS drives in a Ubuntu 10.04LTS RAID 6 configuration for several months with no issues.  I did run into the problem where a drive could not be set to Bootable, but this was caused by the drive  being formatted at GUID.  Once I changed it to MBR  (Master Boot Record ) it was fine to use.

If this did not answer your question, I hope it brought you insight.