WD10EARS Western Digital 1 TB Caviar Green causing ASUS P8z68-v PRO to freeze at logo

For some reason when this storage drive is attached to my mobo (any SATA port) in ACHI or IDE mode, my asus mobo will freeze at the logo - it wont even boot into bios - doesnt get that far - it just freezes

When I detach the drive and let my machine boot into windows, the drive is detected and works perfect.  Ill go to restart my computer and same thing again…freeze at the ASUS logo

I tested the drive using health tools and its 100% operational and detectable in windows.  I have tried plugging it in all 6 SATA ports on the board and same result.  I know all SATA ports are operational as they have been tested with other drives.  I have ran the board in both AHCI and IDE mode - no luck

I have another WD 650GB Caviar Black drive that works with no probs.  And again, the drive is healthy and works once I plug it in after booting into windows.

Any ideas what is going on here, I called ASUS for troubleshoot and of course they said that the drive is faulty - but again, the drive is 100% operational once I am in windows 7

Again, it is freezing BEFORE the bios is able to be loaded - so it doesnt even get that far in the boot process when this drive is attached at power up

please help, this is driving me NUTS!

Have you tried with a jumper on the drive? o.o

im not sure what a jumper is or does.  Can you please explain

Well… The drive has some pins close to the SATA port, using a jumper hunt on a specific combination of 2 pins can physically alter the behavior of the drive.

I believe the OPT1 jumper may be something worth trying. It limits the SATA interface speed.

Jumper Settings for WD SATA and EIDE Hard Drives: