WD1002FAEX 1TB HDD not showing up in my computer

I just built a new computer.  Basic stats:  Intel i5 3570K, Asus Sabertooth Z77 mobo, I am using Windows 8.  I have an Intel 330 series 120BG SSD that I installed first and put Windows 8 on that.  I then plugged in my WD 1TB Caviar Black hard drive, model  WD1002FAEX.

When I go to computer in windows 8, I only see my SSD.  When I enter my BIOS, I see boot order of CD/DVD and then the SSD.  The HDD is not listed.  However, when I click on boot menu in BIOS, it shows my HDD.  What did I do wrong or need to do to fix?!?!

Right Click on Computer and there is a utility to partition drive etc. 

Have Fun

 Thanks so much for this simple advice I finally got my new drive to appear, thank you thank you haha.  I have spent a long time digging through my BIOS and swapping SATA 2 and 3 cables and different SATA ports on my Motherboard for I dont even know how long now. I am glad I found this forum and your post.

I just bought a WD 20EARX for a new build I am using a IntelSSD  120 gb as my primary after finishing the windows 8 instailation I plug in the new WD 2 Tb it show up in my bios corectly but absolute no signs of it in my windows 8 Ive tried to find where to iniailize it but no sign of it in except under drives in device manage it wont show up in computer mangement in storage nor will it show up what so ever in  computer ??   I removed the drive and place it in a  external plug in  drive unit  still no sign of it any where except in bios and under device manager  cant initialize it to format it??

My system build is a Asus PZ77 mini ITX deluxe   CPU 3770k 16 GB of ram  intel SSD 120 GB 520 series GTX 670 all working fine except the WD green WD 20earx   need help