WD1001FALS Disappears randomly on Windows 7 x64

In Windows 7, my second HD drive, teh 1TB Caviar Black disappears randomly from My Computer/Disk Managment. If I am writing to that drive, the process fails.

  1. I have disabled sleep/power save mode

  2. I have tried with both IDE and AHCI in BIOS

  3. I have swapped SATA cables

  4. I have tried reformatting several times.

  5. I have searched for bad sectors

  6. I have run the WD Data Lifeguard Diagnostic, which reports NO errors.

This hard drive is 1 month old, and has done this since I got it.

Anything else I should try???

Thanks for ANY help you can give me!

Same here. My system disk is SSD on SATA II. I have 2 wd1002faex on SATA III. Both are disappearing randomly or freezes. I installed them on a Marvell 88SE91 adapter (onboard adapter on MSI Big Bang), and did not use RAID, No matter what Marvell-driver I use, problems remain although I must say with the latest Marvell driver The disks do not dissapear, they only freezes. I’m already searching a month for a solution.

1 Like

Yes, I should have mentioned too - I am not using RAID.

I’ve updated my BIOS (although my mobo already supported SATA I/II/III) and chipset.

I have the same problem, windows 7 new system, installed OS on a SSD drive and use my WD1002FAEX for data storage in sata3.

When i try copying data it just disconnects and then reconnects 1 or 2 min later

You’re lucky! Mine never reconnects! Once it’s lost, it’s lost until I reboot.

My problem is solved. I had to downgrade the BIOS. So it was NOT the marvell drivers, NOR the hard-disks.