WD10000LSRTL recognized as WD1001FALS

I haven’t been to WD support since I registered my 1T Black back in 2011 but I cannot find either model # as listed in the topic on this site anywhere, even under legacy hard drives…so what the heck is up with that? Anyway, after I noticed several different software inventory viewers were reporting my WD10000LSRTL (1TB Black series 7200rpm 32mb cache) as being model WD1001FALS, I checked my Win7 HP x64 & sure enough, it listed it as the WD1001FALS model. CPU_Z & HWmonitor also thinks the LSRTL is the FALS model. I know internal 3.5" hdd’s use the drivers supplied by whatever OS they’re using, but could this also be why I’m not getting 100% of the performance of said drive? WEI gives it a paultry 5.9 rating. I have the correct & latest AHCI sata drivers by AMD & I’m on sata 6gb connection. Device manager says windows has the ‘best’ driver already installed, so I’m at a dead end here, especially when I cannot find a listing for either drive. The WD1001FALS (according to searches) is also the Black 1TB 7200rpm 32mn cache series. Any advice or ideas how to get it recognized correctly? When I remove it from device manager & reboot, the sata drivers are always re-installed correctly but still says its the FALS model. Does anyone know why I can’t find these drive models on this site anywhere? Thanks in advance!

Hello, I would recommend you to download the DLG from the download section of any of the internal drives and then get the serial number, once you have the serial number, contact support and they will be able to tell you exactly what model is the drive by using the serial number.

Also, have you runned a benchmark of the drive? Can you share the results?

Hello Iluna, thanks for the quick reply. I’m attaching 2 images for you to

I already have DLG installed. I know the model # is WD10000LSRTL it’s on
the box sticker and on the hdd itself. The serial # is [Deleted].

I just want to know why all software, even my OS windows 7 HP
x64, recognizes it as model # WDC WD1001FALS-00J7B0 with the firmware Rev.

Also, can you please explain to me as a WD support customer, why I cannot
find either hard drive model on your support site please?
I find this disturbing. I cannot find any email addresses on the site to
contact support either, just phone numbers…is this the norm nowadays?
I can see now with your email that it’s wdsupport@wdc.com. Please respond.

Thank You


I am still waiting for WD support to answer my question that I have asked for at least four times now…

Attempt #5: Why is my WD model no where to be found on this support site?
WD10000LSRTL (1TB Black series 7200rpm 32mb cache)
Neither is the WD1001FALS model which Win7 HP x64 ‘thinks’ is installed on my system.

Support emailed me and stated that the “RTL” in my model number means “retail” and it is the “LS” model. That certainly clears things up. NOT. The model # on the box sticker and the hdd itself says WD10000LSRTL but I cannot find it on this site. Perhaps it is indeed the WD1001FALS model (also NOT found on this site, but hey, here, have a .pdf, that’s all the support you need right) but I don’t see why they have to confuse the end user with all this distributor/resell/re-branding/re-labeling bs and just have the correct model number on it to begin with. Seeing that it’s over 5 years old & out of warranty but still performing well, I guess this problem is solved, still leaving the consumer in the dark. Samsung here I come.

I ran AIDA64 Extreme & discovered that my WD 1Tb Black HDD is running in SATA II (3Gb/s) and not SATA III (6Gb/s). The main reason I bought this mobo (ECS A890GXM-A v2.0) is because it supported sata III. The hdd has NO jumper pins (default) on it & is securely connected to power supply, the data plug on hdd & the mobo. AHCI is enabled in BIOS & the sata drivers from AMD are correctly installed.

After more time-consuming research & looking at the packaging it came in, it does not state anywhere (simply SATA) that it IS a SATA II (3Gb/s) drive but it looks like it is, considering it was made in 2010. I don’t think it matters if it’s on a 6-3-1.5Gb/s mobo, considering the fastest rate on mechanical hdd’s is around 150MB/sec (1.5Gb/s aka sata I) so apparently all is connected & performing as it should be. So, to summarize:

  1. The model as listed on the box and hdd plate says its a 10000LSRTL when it’s really the WD1001FALS with SATA II.
  2. If you ask a direct question here, even multiple times, you still won’t get a direct answer.
  3. Do not reply to a WD support email from your OWN email client with any private information such as serial numbers, personal data etc. because it will likely get posted immediately to your support post here without warning!
  4. Do not expect WD support to help or follow up on your concerns unless you keep on them night & day. Your best bet is research & help/advice from forum users.
  5. Don’t expect to find support for your Black series model # hdd on this website if it’s over 2 or 3 years old.

TL;DR: Do your own troubleshooting & research unless time & money aren’t high on your priorities list.