WD Utilities for Mac completely stopped working

New to the forum so hope this is the right section for my request of support…

I have a 4TB My Book Thunderbolt Duo and a 3TB My Book and my problem is with the WD Utilities software for Mac [Os X El Capitan 10.11.4 (15E65) – version of the WD Utilities installed].

Every attempt at opening the software results in the message WD Drive Utilities quit unexpectedly.
Searched and found a newer version ( but it wont install with the same error: WD Drive Utilities Installer quit unexpectedly.
The uninstaller gives more of the same: WD Drive Utilities Unistaller quit unexpectedly
Also tried WD Security (version and WD Security Uninstaller: same result.
Every WD software unexpectedly quits, even when launching in safe mode.

I haven’t installed any software and/or Hardware since this happened, so I don’t see what could cause a conflict there…
Is this a compatibility problem with the newest El Capitan?

Thank you for any help


I recommend you contact WD Support directly for assistance with this issue.

Thanks for the tip and the link.
I will try, but since this is a software and not a hardware problem I guess not much help will come from that side

I have a very similar issue. I have a MyBook for Mac external drive. I’ve downloaded the latest utilities from WD and when I launch the software to install it quits unexpectedly. I’ve removed all other WD Drive Utilities and this still happens. I have a iMac with OS Sierra. I don’t know what is happening?