WD UI publicly accessible without login (help)

I have the newest firmare (v4) and i have started using monsta ftp (with ssl) on port 80
I liked it to my domain however every time i type in my domain address (which is forwarded to a www.domain.com/ftp subdomin ) i access the UI instead

Once i have accessed the UI like this i can edit all the settings without any form of username or password.

How can i disable the publicly accessible UI while still having it privately accessible (local network).

What happens if you remove the edits you made which were posted to the other thread? Is the UI publicly available (remotely) then?

Generally the My Cloud OS is supposed to reject remote access to the Dashboard from outside the local network. Its possible by making the changes you’ve indicated in the other thread that you removed the remote UI access block.

yea i already tried removing monsta FTP.

I was thinking it may be possible to make a second apache server and run it off a second port, then add monsta in there instead and block the port using firewall/iptables

With port 80 being port forwarded to the My Cloud, the Dashboard UI will remain accessible so long as one is on their local network. Once on a remote network, one should receive the following message instead when trying to remote access the Dashboard:

Forbidden

You don’t have permission to access /UI on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

I dont understand why even though i set up a redirect to domain.com/ftp it always sends me to domain.com/UI

What happens if you set the redirect to just domain.com and drop the /ftp. Then in the web browser append domain.com to domain.com/ftp. What happens if you access your My Cloud by your public IP address rather than the domain name?

In my quick testing I have no problems accessing the FTP portal by having the router port forward port 80 to the My Cloud, then in my web browser use: http://<public ip address>/ftp.

i can manually add the /ftp and it does work. just the auto redirect just reverts to the /UI

e.g.
< ip addres> -> /UI
< domain.com> -> /UI
< ip address>/ftp -> /ftp
< domain.com/ftp> -> /ftp

the domain is set up with the ip address (A record) set to my public IP, the www. subdomain set to webspace and the domain redirected to www.(subdomain).net/ftp

Nothing got to do with A records or what so ever :stuck_out_tongue:

If you insist on what you’re trying to achieve, you got few options:

1.
cp /var/www/htdocs/index.html /var/www/htdocs/index.html.BACKUP;
sed -i 's/\/UI/\/ftp/' /var/www/htdocs/index.html;

WARNING, you’ll then need to access your MyCloud Dashboard by manually appending the path i.e. http://192.168.1.x/UI because it now redirects to /ftp by default. If you know HTML/JS you could easily make this file route to your desired paths :slightly_smiling: This is the easiest method without knowing CGIs.

2. Add another port listener directive like you mentioned and forward the appropriate port on your router. Don’t forget to restart Apache2. But if your router doesn’t support PAT (Port Address Translation), you will then have to access via the not so good looking ‘domain:port’ :frowning:

3. Modify to use virtual host directives. I’ve done this before in the past to host multiple websites on MyCloud’s Apache2 but now I’ve switched to the faster Nginx+PHP-FPM :wink: