WD TV Streamer does boot loop if router is disconnected from WAN (internet)

Very very deprecable bug!!

If wd is connected to the router but there’s not internet connection, it does boot loop.

I had to detach LAN cable, thus being unable to stream though LAN, till my ADSL turned back.

Very uncomprensible bug!!!


Hi LittleWizard, this is not something normal, have you tried to contact support so they can help you find the cause of the problem? 


searching forums I found other people with same issue…

Really? I haven’t seen this mentioned so far.

I just found this post. This is happening for me as well which is really frustrating since I don’t have very stable internet. I just opened my second support case on this issue after only getting “helpful” generic responses suggesting all that I already tried (and mentioned trying in the support case).

I hope someone from WD reads this and opens a bug for the firmware devs.


Mine has stopped doing that.

I have done a full reset as suggeste. I was sceptical, but it solved… maybe some misconfigured parameters due to updates.

Anyway I haven’t retried disconnecting it after latest major FW update.