WD TV Live Streaming network conflict with Security Camera DVR box


Can anyone help with this problem please ?

I’ve googled it and searched on here and haven’t found anything like it mentioned before.

I’ve posted on this forum before about my WD TV Live gen3 box freezing whenever connected to my home network (by wired or wireless connections).

It works perfectly when not plugged in and wifi not enabled, but the moment it’s in contact with the local network it freezes with the spinning arrow symbol, and then needs a full cold start, and then it immediuately happens again.

I then read somewhere that certain other devices can conflict, so I gradually unplugged each item to see if it showed up.

I have two routers, a switch, five PCs and a Mac, and a self contained security camewra recorder box, a Sentinent DVR-4CIF with a wired ethernet connection.

When I unplugged that, the wd tv live started to work perfectly with the network connected, and even playing files over the network on windows shares on XP and Win7 drives.

So, the problem is that the WD TV live and the Sentinent DVR can’t co-exist at the same time, though each works perfectly when used over the network otherwise.

I’ve always used both  with different static IP addresses.

The DVR has some other network settings that I am not familiar with, could they be the problem ?

media port at 9000

 web port at 8090

DDNS enabled

service 3322  (with an alternative option of DYNDNS)

PPPoE Enable is set to “off”

Is there anything I can alter there, or on the WD TV live ?

I’m out of my depth here, any help or suggestions would be much appreciated.

See if setting a static IP for all of your connected devices, helps with the problem. You can also try making the WDTV part of a different workgroup. Check page 190 of the manual for more information.



1 Like

Thanks for the reply Ichigo, all suggestions of help are much appreciated.

I have about a dozen regular devices on my home network, and I’ve always set up static IP addresses for them, and kept the routers DHCP address range in a group away from them, (for when friends and family use my wifi with mobile phones etc.)

The WD TV has always been set to and my security camera DVR is on

I have got everything set to “home” as the workgroup, so I will try changing the WD TV Live to something else and then let you know how I get on.


No luck I’m afraid.

I tried changing the workgroup on the wd box to a different one from the rest of my network and the dvr box, and cold restarted it.

Exactly the same problem though. When the DVR and the WD are both connected, the wd box freezes as soon as I try to play anything.

When either are unplugged, the wd box works perfectly.

The DVR box works perfectly all the time with the network, whether the WD TV box is plugged in or not.


I’ve been digging around in the Security DVR box’s network settings, and have now disabled two services in the network settings:

PPPoE  defaults to “enabled”, but I have no switched it to “disabled”

DDNS defaults to “on” with service set to “3322”, and I’ve now set it to “off”

I don’t think those changes will affect my use of the DVR box, I can still view the cameras from any PC on my local network, which is the only function I was using.

The WD TV box now works perfectky with the DVR box connected to the network at the same time.

Presumably the WD TV network firmware was clashing with the PPPoE or DDNS services from the DVR.

Don’t forget to set thread status to solved.