WD TV LIVE PLUS won't play ntfs

First time poster…

I’ve used a 3TB Seagate ext drive (formatted for ntfs) with my WDLIVE for a few months now and after i formatted again and put my files on it yesterday and will no longer detect it.  (usb LED flashes on the media player for about 20 seconds and nothing).

I’ve have the most recent firmware, i’ve reset to factory…even a 16GB USB stick won’t be detected with NTFS… 

Everything works under fat32…easily detected…

I know there have been other discussions on detecting harddrives…but nothing about it working and stopping.

any help will be greatly appreciated.



Not sure why is doing this, but have you tried resetting the media player?

I have reset it and reset to factory settings…I’ve tried different drives and everything.  It was working and now all of a sudden just won’t play ntfs…tempted on finding a different media player.

Let’s see if I understand:

You formatted a drive that used to work on the WD player.

After you formatted it, it does not work on the player now.

Maybe it’s not the player that is at fault, maybe the format job went wrong.  Have you EVER formatted this drive before – successfully, and for the WD?  Maybe you ought to format it again (and check it before you load up all the files on it again)

Do you have another drive formatted NTFS you can connect to the player to check things out?.