WD TV Live Plus HD - all file types Video Stutters, no Audio, worked fine before! Help!

Hello All,

I recently updated my firmware to 1.06.16_B and even on the previous version, when I open video files on shared network drives regardless of the file type (mostly AVI) it takes 15-20 seconds to load, then the framerate is incredibly slow and there is no audio.  If I fast forward for a couple of seconds, the audio will come back for a moment, then the frame rate will drop and the audio will cut out.

I don’t understand why this started happening.  It worked perfectly  before the firmware updates.  I connected to my network over an ethernet to a wifi client bridget with a G connection.  Then I tried one of the compatible wireless-N adapters (Airlink101 AWLL5077) and it still stutters/drops audio!  I tried reseting the wd tv too and everything still stutters.

I am at a loss.  I don’t know why this started happening now when everything was working fine before.

Any help is appreciated.  I guess my next step is running a looooooong ethernet cable to my router/switch to see if that makes a difference.  Even if it does, the video streamed flawlessly before so I don’t see why I have to run cable when it was working.

I should also mention, I recently setup a media server on the same machine that has the video files, and the media server streams the same video files just fine, so that proves to me that it isn’t a network bandwidth problem and instead a problem with how WD TV handles files streamed over shared network drives.


UPDATE 1: Firmware 1.03.49_B does not have the stuttering issue.  More details below.

UPDATE 2: Firmware 1.04.22_B stutters on both ethernet to wifi client bridge, and on the wireless-n dongle.  Media server plays fine.

Update 3: Firmware 1.04.31_B also stutters on both wifi client bridge and wireless-n dongle.  Media server works fine.  Well…it looks like the only firmrware that can reliably stream over network shares is 1.03.49_B.  And in that case you won’t have the latest internet apps like radio, accuweather etc.


Yep…  Run that looong ethernet cable.    If it works, then you know it’s a WiFi problem.

And since you’re using a Client Bridge (which, too the WDTV looks like wired) you’ll know it’s the WiFI ENVIRONMENT, not the WD that’s causing the issues.

TonyPh12345 wrote:

Yep…  Run that looong ethernet cable.    If it works, then you know it’s a WiFi problem.

And since you’re using a Client Bridge (which, too the WDTV looks like wired) you’ll know it’s the WiFI ENVIRONMENT, not the WD that’s causing the issues.



The same video files stream flawlessly when connecting to a media server on the same machine using the client bridge and wireless-n adapter.  I setup the media server temporarily to troubleshoot the wifi.


I rolled back to firmware 1.03.49_B.  Now I can stream over my wireless-n dongle I mentioned in the original post without stuttering.  It takes 10-15 seconds to buffer initially, but once it gets going it’s smooth.  No dropped audio and framerate is retained.

I then tried disconnecting the wifi-n and connecting the ethernet to wifi client bridge with G connection.  It actually loaded up faster than the wireless-n dongle and there was no stuttering!

So far this looks to be a firmware issue.  My next step is upgrading 1.04.22_B per someone else having a similar stuttering issue in this thread:


I hope WD sees this and does something about their firmware.

Bump so more ppl can see my updates today.

I have the exact same issue, but it seemed to work fine even after I upgraded the firmware (at least I think so). The issue seemed to start after a recent Windows 7 upgrade, but to say that’s the cause would be pure speculation. Hard reset did nothing to fix the issue. Aside from audio cutting out - and then going back on for a few seconds after FF - the video is also not a s smooth. Everything had worked fined for over a year until recently.

Netgear wireless N router - perfect connection at maximum speed
Windows 7 64bit ultimate
WDTV live Plus HDMI output Sony Bravia LCD
I will try to roll back the firmware, but this is unacceptable. I had been a huge fan of this product, and hope someone at WD is reading this and will fix it. My guess is that in attempt to include too many bells and whistles in the upgrade, someone forgot about core functionality.

Update: downgraded from 1.06 to 1.05 to 1.04, and issue persists. No problem playing same media via USB. I can only conclude that something in the latest windows update somehow affected it. This **bleep**!