WD TV Live only working in certain rooms of my apartment


I have a very odd issue with my WD TV Live Streaming Media Player, I would be grateful if anyone could shed some light on.

Basically, whenever I try to power-up the device from the living room of my apartment, the box gets stuck on displaying the WD logo and the words ‘Connecting Network…’ beneath. It is completely frozen and it’s not even possible to reset the device using the reset button underneath the box. It doesn’t respond at all.

I have tried it using several different plugs in different areas of the living room and still get the same problem. However, when I move the same television and the box to any other room of my apartment, it loads fine. I have also tried the box at my office and it works fine there too. 

I updated to the very latest firmware last night but this doesn’t seem to have helped. The only thing I can think of that is causing the problem is some kind of interference or a problem with the electricity in my living room. However, I have not had any problems with any other electrical appliances in this room. 

I have also returned the box once, and so this is the second box I am having exactly the same problem with, so it’s unlikely to be a faulty unit. I also get the same problem using both HDMI and composite connections.

Any help with this mystery would be greatly appreciated!

Which firmware were you using? 1.13.18

What exactly happened? Box freezes on boot-up (stuck on ‘Connecting Network’ message) - only in living room of apartment. Works fine in other rooms.

What you were doing? Powering up box.

What hardware and media were you using? WD TV Live Streaming Player

Does it happen every time? Yes 

Does it happen with previous firmware? Yes

Does power cycling the unit solve it? No

Does resetting to factory defaults solve it? No

Have you tried this on other devices? N/A


Steve (Australia)

I guess you are using a wireless connetion, might be a problem with a low signal.

Thanks for the suggestion, but the problem was happening even before I set up the wi-fi connection on the box.

It was just freezing when I got to the main menu instead.