WD TV Live+ Network Share Problems

So, heres the deal, 

I got my Live+ connected to my home internet using an ethernet cable and the connections working fine. The problem is that the network share wont work! It worked once today randomly. I restarted the device and it suddenly stopped working again. My computer just doesnt appear in the network share area. So i went googling, as one should, and then i tried the “net view” command in the command prompt, resulting in: 

"System error 6118 has occurred.

The list of servers for this workgroup is not currently available"

So once again, i went googling the heck out of this. People were saying that its the firewall thats causing this problem, so i turned off my firewall and tried it, still nothing. I then restarted my computer and my router but it still wouldnt work. Then i read around and someone mentioned a “master browser” and other terms i wasnt familiar with, so I tried checking how I can set my computer to the master browser but I couldnt find a way.


Win 7 - Ultimate
WD TV Live+

Netgear router

Any help would be greatly appreciated!