WD TV Live Model - WDBHG70000NBK-HESN No Subtitles

WD TV Live Model - WDBHG70000NBK-HESN
Windows 7 Home Edition
Media Server - Twonky Manager
Latest Firmware
Issue - Subtitles will not display

I have installed the above media player and everything seems to work fine except subtitles will not appear.  I stream movies, mostly AVI/Xvid/Divx from a 3GB external HD from my computer.  I have checked and rechecked to make sure the .avi and .srt file have the same name and are in the same folder.  In the setting I have tried both Subtitle Default On and Off.  When I attempt to play a movie with subs, I start the movie then press the “Subtitle” button; “Subtitle: OFF” appears, toggling the button has no effect .  Under "Subtitle: OFF Audio 1 - MPEG is displayed.  When I press the “Options” button nothing appears.  Last night a drop down menu appeared a couple of times, but selecting the subtitle button had no effect.  Also last night, when toggling the Subtitle it went from “Subtitle: OFF” to “Subtitle: UNKNOWN” but I can’t duplicate that result today.  I have followed the Owners Manual exactly with no results.  I scrapped my old D-Link DSL 250 because it did not have Subs.  Very frustrated.
Any assistance greatly appreciated.


External subtitles aren’t supported via DLNA servers … only subtitles that are imedded in the media file will work.


Thank you for your reply, but why does the Owners Manual state that this player will handle srt files?

The WD only supports external subtitles over samba, not dlna.

External subtitles are not part of the DLNA spec. However, there a quite a few brands which support an extention to enable this. (like samsung with twonky). It would be nice if WD also would support this.

Connect to your drive via network shares.

I had a similar issue when I hooked my HD directly to my WDTV SMP… I hooked it up to my main computer instead and connected the WDTV to the network shares option. At the same time, I renamed my srt files to include language type:
Transformers.srt —> Transformers.Eng.srt

I’m not sure exactly what fixed it, but I have subtitles now…