WD TV Live HD - Won't stop playing

Greetings all, just wondering if anyone else is having the same problem I am?

On My WD TV Live HD, when playing over-the-air TV recordings from a Mythtv server,  or from a completely separate NAS box, for many months now, I have been finding that after a few minutes of playing, I will not be able to stop the playback.  

Even turning it off with the remote will not stop playback (even though the power light goes off).  The only way that I can get it to stop is to pull the power plug.   

Similarly,  if a recording plays through to the end, it will stop, but I am unable to play anything else until I pull the power plug and restart it. Attempts to play anything else will get the blue rotating circular logo thing.  However if I catch it within the first minute or two of playback it will stop quite happily.  This happens roughly three out of four times that I play anything.

Although one might think that it is simply a faulty device, I’m finding this is happening on two separate units, from two different sources.  They were not from the same batch as they were purchased about a year apart.  They have not always done this though, I’m wondering whether a software update a while ago had some effect, although I have also tried re-flashing it back to the original version it had, with no difference.  

On the thought that maybe it is the Mythtv system, I have also rebuilt that system from scratch and it made no difference. I thought maybe it might be the DVB-T encoded MPEGs that it records, but I am also seeing it on FLV’s and others sourced elsewhere and played from a NAS box (ASUS NAS-M25)

I find it strange that it is happening on both of the units that I have, from any source I have, and yet I haven’t seen it mentioned anywhere here.

Is anybody else seeing this?  I note for background information that I am in Australia, so maybe it is a problem with PAL playback? Or the composite output?  or non-widescreen?  (yes, can’t bear the idea of throwing away my 29 year old TV set…) Or just my bad luck?


Have you tried performing a factory restore on the media player?

Also you may try to reset the media player.