Wd tv live gen3 with firmware 2.02.32 it crash/stuck many times

Hi why with the latest firmware of this product the media player it crash/stuck a lot of times.

Something that is doesn’t happening with the firmware 2.01.86.

DON’T suggest me to re-install the old firmware because you simply MUST release a newer firmware that simply work without crashes of the product.

After all this is YOUR CREATION so…


Have you tried a reset and/or power cycle?

I know maybe you have already but i just wanted to point out that it is always recommended to do at least a power cycle after a firmware update.

Yes i did and from the back of the product with the reset button but still the same it crash a lot of times and as i see this is common situation with the latest firmware of this product.

So CAN’T you release a CORRECT AND STABLE firmware for this wd tv live gen3 product?

I had the same problem tha last 48 hours… after 20-25 minutes of playing videos the wd tv live stucks /crashes …
Try to close the WI-FI this will probably fix your problem…

I know this is not a solution its temporary, They must release a new firmware and find out what causes this problem…

Are you sure that with the latest firmware and with wifi disabled the product doesnt crash so often?

And i DON’T have connected with internet with wifi but with lan.

And stil with the latest firmware crash a lot of times.

How i completely disable the wifi?

Hello fits79 !

Just disconnect your player from the internet, remove the lan cable and don’t put any password to the WI-FI … Then restart your player and try to watch a movie or a  video and tell me if this temporary fixes your player…

So you suggest to completely disconect the internet(Lan or wifi) this product so i don’t have crashes?


This is not a solution(Even temporary solution) at all because i need this product have access to the internet so this resolution is completely useess.

The onnly SAFE way is to return to the firmware before that release at 2.01.86 it was the crash proof firmware on that device.

So to the wd community/developers PLEASE create one STABLE new firmware for that device.

Hello fits79!

As i said this a temporary solution that i tried…

I wrote it here because i want to help the WD to locate the problem…

I know that the problem is the firmware or something else…but i am not working for WD to find the final solution…

So lets hope that someone will care about us and help us with a new firmware update…

Have a nice day :slight_smile:

I don’t thing wd thing about us anymore with that product.

I believe it has forgotten us because this product is too old to support it anymore so the only safe solution is to return to the previews firmware 2.01.86

Hello all,

Please note that this is a user to user community that was created for you guys to help each others.

Please keep this friendly. 

I have exactly the same problem. Aparently WD left us no choice but to buy another device. After almost a year since the last update it is very unlikely they release a new version to fix our problem.

Hello All,

I have the same problem the same proxy version, any idia on how to downgrade the firmware?, also my equipement gets warm, and taked so long to initiate and compiling the external Disk Drive.

Hi there! As i found in a different topic comparable problems with the wdtv smp that came up in the last days i tried to DISABLE the WiDi (wireless display or miracast) in the network settings… Finally no more hanging up or not answering the remote control… and the best: the responsiveness of the state before last years firmware update is back!!!

working fine for the last 3 hours!

Why are we talking about the SMP in the WD TV forum?  

The forum for the 2011 WDTV Live Streaming Media Player is here: http://community.wd.com/t5/WD-TV-Live-SMP-Discussions/bd-p/streaming_discussions

This forum is the 2014 model.