WD TV Live cripples my network


#1

I’m running the WD TV Live with the latest firmware and Buffalo WLI-UC-GN wireless-N USB adaptor and with a D-Link DIR-655 wireless-N router. The problem is everytime I turn on WD TV Live it resets my router every minute or so (other wi-fi and wired devices connected to the router keep disconnecting and reconnecting). I’ve already tried the DHCP reservation and the server in WORKGROUP solutions and it still brings the network down.

Any ideas?


#2

Welcome to the forums.

Are you hard assigning an IP address to it?  I’d sure try that.


#3

Is it actually REBOOTING the router, or just knocking the clients off?   If it’s rebooting the router, I’d check to see if there’s a firmware upgrade available for it.


#4

Just tried that and got the same results. Also tried a different wireless-N USB adapter (Trendnet TEW-644UB) and while it did work pretty good initially and was finally able to play a MKV, it eventually flaked out and I got the same result again (router going down, all device’s connections dropping).

Any other ideas?


#5

@TonyPh12345: well the router has never ever had this issue before with any of  the 20 - 30 various devices I’ve connected to it over the years, so I doubt the problem lies in the router or it’s current firmware.


#6

I had a problem with a device (not WDTV) which took my network down and that turned out to be due to the firmware in the router. In fact I had to downgrade the firmware in the router to solve the problem. I am not saying that this is your problem but when troubleshooting it is imperative that you keep an open mind.


#7

In my opinion, it is, by definition, the router’s problem.

There’s NO excuse for ANY type of network traffic causing a network device to reboot (actually, you never answered my question if that’s happening.)   If it does do that, then the router is quite susceptible to what’s called a “Denial of Service” attack, which means its software is a security risk.


#8

@richUK: very true

@TonyPh12345: Yes, the router is rebooting itself, not just kicking devices off.The only other time I’ve ever saw this router have this problem (rebooting itself over and over) is when you enter a domain name instead of an IP address for the NTP server. There is a firmware update for the router, so I’ll try that.


#9

No luck :frowning: I’ve tried just about every reported solution for this problem: I upgraded the firmware, toggled QoS on/off on the router, made the NAS (which serves the network shares) the local master browser and no matter what WD TV Live still brings down the network. I’m just gonna give up. I’ve never had this much trouble getting something to work in my 15 years as a tech enthusiast, smfh!


#10

Thanks everyone for your help


#11

So I got my Biggie on and gave this darn thing one more chance - as a test I swapped out the router (D-Link DIR-655 hardware version A4 with 1.34NA firmware) with my DD-WRT router (Linksys WRT54G v2 with custom firmware DD-WRT v24-sp2 (12/18/09) Standard, SVN revision 13491M VINT Eko) and BAM! No more connection drops! No more bringing down my router and network.

So you guys were right, the D-Link router [or firmware] isn’t liking what WD TV Live is trying to do which is weird because the DIR-655 ison the list of supported routers. Anywho, the Linksys router isn’t wireless-N so that’s not a permanent option. The D-Link performs superb outside of this WD TV Live issue, so I’m still not getting rid of it. Plus the WD TV Live chokes on most of my MKVs video files (tested under wireless-N/D-Link for the 5-10 minutes it was working), so I guess I’m still giving up on it.

Interesting find though.


#12

I have the same problem and there is an another thread about this problem…  http://community.wdc.com/t5/Networking/WDTV-live-drops-connection-after-a-few-minutes/td-p/32972/highlight/false/page/3 

But there is no solution. :-/