WD TV Live cannot see network pc external drive

I’ve been using my WD TV Live for years with a network share PC where all of my videos are kept.
I recently changed the network pc to a mini PC with an external WD drive attached to it.
From the WD TV I can see my media PC ok and can connect using either windows media server or plex media server but if I try to connect to it as a network share, all I can see are the user folders and not the libraries which are stored on the external drive.
Is there a way to fix this because it’s driving me nuts?

Thanks in advance.

First thing to check … WD TV Media Players use SMB1 for Network Shares

If you’re using Windows 10 on your Mini PC … then SMB1 is disabled (for security reasons)

You can however re-enable SMB1 in Windows 10 if you wish. (just google … windows 10 re-enable smb1)

Hi Joey,
Thanks for the reply, I have already enabled SMB1 on my media PC.
I’ve also tried re-sharing the drive, folders, turning media streaming off and on, using no password for network sharing and enabling the sharing for devices that use 40 or 56 bit encryption.
It’s all very odd, I even created a folder within the user folder with a video in it and that works ok although that would be stored locally on the pc and not on the external drive.

I can’t believe it but I’ve actually managed to find a solution to this from searching for similar problems accessing removable drives over network.
This fix worked perfectly.

  1. Click Start, and then click Run.
  2. Type regedit, and then click OK.
  3. Navigate to the following key:
  4. In the right pane, double-click the IRPStackSize value.
    NOTE: If the IRPStackSize value does not already exist, use the following procedure to create it:
    a) In the Parameters folder of the registry, right-click the right pane.
    b) Point to New, and then click DWord Value.
    c) Type IRPStackSize.

IMPORTANT: Type “IRPStackSize” exactly as it is displayed because the value name is case-sensitive.
5. Change the Base to decimal.
6. In the Value Data box, type a value that is larger than the value that is listed.

If you created the IRPStackSize value using the procedure described in step 4, the default value is 15. It is recommended that you increase the value by 3. Therefore, if the previous value was 11, type 14, and then click OK.
7. Close the Registry Editor.
8. Restart the computer.

Actually for me the solution worked only after changed the decimal value to 30.