WD TV Live auto meta-data issue

Hi, I have my media library set up to access my NAS trough wifi, which is working fine, but I want to make use of the auto fetch meta-data feature. I have my TV shows named like this: “Title S01E02.avi” but the box does not seem to find/fetch the meta data for one of my shows. I found out trough try and error, that the WD TV Live will not download meta-data if it finds more than one result for a given file. When I try to manuall download the meta-data of said show, it will show me a dialog where I can choose between two entries, which are labeled exaclty the same, and also have exactly the same content data behind them. Also, both these results are coming from the integrated default tv-show database, not the movie one.

I experiemented a little with different file naming patterns, but the results are always the same two eqal entries.

Since I don’t want to do this manually for more than 100 files, how can I get the box to just take the first result instead of doing nothing?


Edit: I don’t want to use some external program to find the meta-data. I tried several ones, but I like the results of the integrated meta-data feature the most and thus I want to use it.

sebastian621 wrote:

…it will show me a dialog where I can choose between two entries, which are labeled exaclty the same, and also have exactly the same content data behind them

What’s the exact show name?  I’m curious if TVDB has a problem in their database.

It’s Grey’s Anatomy. You should be able to reproduce this by naming a file “Greys Anatomy S01E01.avi” and doing manual content info search.

I also tried to search their database at the website, but that gives totally different results (ie. other languages, fuzzy searches etc.)

Also, I inspected the generated xml files for both entries and they both had the same show-id in there (73762).

Ok, dumb question –  Have you tried including the apostrophe in the file name?

“Grey’s Anatomy S01E01.avi” 

instead of 

“Greys Anatomy S01E01.avi” 

WITH the apostrophe, it’s an exact match on TVDB.  Without it, it gets some 20 hits.

Yes I tried that. It wasn’t changing the results at all.

I’m still getting many different results even with the apostrophe: http://thetvdb.com/?string=Grey%27s+Anatomy&searchseriesid=&tab=listseries&function=Search

Hmmm.  Indeed.   

Their search API seems unpredictable.

When I type “Grey’s Anatomy” in the search box and hit enter immediately, I see what you see – lots of hits.

If I type “Grey’s Anatomy” and wait a few seconds, a little pop-up appears under the search box with a single exact match.   When I hit enter then, I get taken directly to the series.


Strange indeed, but doesn’t fix my problem. As I mentioned earlier, even my WD TV only finds one show ID, but still is showing it in two entries in the result list, both seemingly leading to the same database entry. That’s why I think it might be a bug in the firmware (latest, of course).

I was hoping for some kind of workaround.

sebastian621 wrote:


I was hoping for some kind of workaround.

You sorta dismissed the only workaround I can think of – use an outboard scraper such as the tool I wrote, the XML Fetcher.

As far as “results” go, it’s going to give you the same content as the WD’s internal scraper, just in a predictable manner.

Well, if that tool gives me that same results as the onboard algorithm, I’ll give it a try, thank you very much!