WD TV Live 3gen Network Share not working

I have a WD TV Live 3gen and a Macbook Pro. I recently updated my Mac to OS X Maverick and found I was able to transfer files from my computer to my WD MyBook, which I have connected to my WD TV. This hadn’t worked before, although that might have been because my lack of techskills. However, since the update I’m no longer able to log in and stream files through the “Network Share” function. When I first installed the WD TV I simply log in with the pre-set “anonymous” & “********” log in, but now I get an error message saying either my username or password is wrong. I haven’t found anywhere in my Mac where I can change it and I have tried the “Mac password” (donät know what it’s actually called) but it didn’t work. I even tried my Appstore log in with no luck (duh…)

If anyone knows how to fix this and is able to explain it to a tech-moron I’d really appreciate it!

P.S. I also recently updated to the latest WD TV Firmware (can’t remember which version or where to find it). I think this is unrelated as I think it worked both before and after the update, but I can’t remember for sure


As a recommedation, check the network settings on the Mac to make sure that you are allowing the folders to be share.

Check the following link as it might help.