WD Sync pending (all time)

Hello!
Several days ago i bought WD My cloud (3 TB). I need some kind of dropbox replacement.
At the beginning all was going pretty well. I create 1 user, installed WD Sync on 1 PC (Windows 8), synchronized it fully (100%, i checked it), and then add 3 more PC (windows 8 and 10) and 1 Mac (El Capitan) with the same user. At this moment something started to going wrong. Mac and 2 PC get 100% sync, but 1 PC didn’t, WD Sync saying that you’ve installed the newest version of your cloud", but the difference with space was nearly 600 mb. Then one 1 PC i changed several files (i needed for work), and status “pending” permanently stuck. All computers (PC and Mac) have always Pending MyCloud (105), i was trying to reinstall it, rebooted it, renew the base, reboot mycloud and e.t.c.

Any suggestions?

What can you share with regards to the original system that was not synchronizing? What operating system does it run? Does it have a particular network configuration or is it part of a domain? Is that computer able to access your WD My Cloud through the network?

"What can you share with regards to the original system that was not synchronizing? " <- don’t quite understand your quiestion :frowning:
As i said operations systems are: 1 Mac (El Capitan) and 3 PC (Windows 7 and 8).

There is no local network, all computers are in one town but not in local network. They are connected through internet connection. I cannot get direct connect to WD My Cloud because he is standing behind NAT (internet provider) and router.

You indicated you had three PC’s (Windows 7 and 8). What Trancer was asking with his second question was; what is the operating system on the one PC that isn’t syncing properly, is it Windows 7 or Windows 8?

Can you give more detail on your troubleshooting steps and how you have WD Sync configured on the one computer where it is not working properly? Have you tried uninstalling the software, then reinstalling the software? Is there a lot of content, especially large files, in the folders being synced? How is that one computer connected to the network, via WiFi or via Ethernet? Are you syncing each of the computers into their own folders or into one folder for all computers? Is the sync Share/folder on the My Cloud set to Public or Private?

Bottom line is some are having trouble with WD Sync and in certain cases it just doesn’t work as claimed. Some have resorted to dumping WD sync (uninstalling it) and using a 3rd party sync program. Free File Sync (http://www.freefilesync.org/) is one such program some here use instead of WD Sync.

I have the same problem. WD Sync is a terrible product. In the past I kept getting “Sync is Missing” then after some updates it worked okay (not great). Yesterday, it started with this “pending” nonsense. It is behaving the same from my PC and Android device. WD Sync does a terrible job anyway; I pulled a file from WD My Cloud and it is 3 days old. It should be at the most one day old, I use this file everyday.

The best solution I have is using FreeFileSync and syncing the files when I get home. At least it is reliable.

And for WD this is NEVER a network issue. I can always get to my WD cloud storage from either the network when I am local or from WD My Cloud.

WD Sync is a horrible product. Don’t know what WD is doing, seems sync should have an index on the user Device and on the WD Cloud and sync should compare the two indexes. Then copy new and updated files. Maybe check the indexes on startup and every hour.

Did anyone ever find out a solution to this? I’m having the same issues with a Mac Book Pro and Window 10 systems. I’m trying to sync to 2 folders in the drive location G:/Folder1, G:/Folder2. They’re not the My Cloud default folder created. I added them.

Getting really odd behavior and can’t get anything to sync up properly with the main drive…

Constantly pausing syncing, can’t sync files for unknown reasons and just stopping and saying it’s up to date when nothing is synced…

Just switched over from Dropbox after several years and am excited and hope this is just a simple issue…

I have a file that has too many characters, the dreaded 200 character thing, where it is in a bunch of sub folders so says too long in explorer when copying or deleting. So when Sync it says unable to sync will try later. I deleted the entire folders and sets of folders above it and it still tries to sync what is no longer existent. I tried exiting Sync, re-configuring the MyCloud Mirror and rebooting it, it still tries to syn a nonexistent file. It also does it with a microsoft pst file for some reason.

I am trying to figure out how to stop it from trying to sync nonexistent files and giving me the alerts it cant sync! Help

In my opinion, no need to try anymore , at least ! I won’t do it again ! because I really got bored !

More than 3 months, I have been dealing with the same issue, 2 days working 5 days not, and really IT’S ENOUGH ! it’s working with my mac but always having problem with windows.

I bought that unit (my cloud ultra ex2) to make my work easier, but in contrary, I am spending my time to read forums ! asking help from the team, trying to do what they advised !

Western Digital, you didn’t make a nuclear plant ! you sold the device, and you are obligated to prepare the software suiting with your unit and recent operating systems… and I am not your IT technician to do this , to do that, to try so and so…

Sync is working OK with files that I change - but there are 14 that it continuously cycles through trying to upload them and then giving the error message - cannot sync - will try again later. When I look in the folder - the file doesn’t exist (yes I’ve got hidden files box ticked). How do I delete this from the snyc list. The hard drive on the WD NAS is constantly spinning unless I pause the sync

One option is to dump using WD Sync. WD has moved that software to End of Support and now appears to suggest one use Goodsync instead for syncing files to/from the My Cloud.

WD Sync End of Support
https://support-en.wd.com/app/answers/detail/a_id/29023

GoodSync Free and Premium for WD My Cloud

WD has partnered with GoodSync to provide backup and synchronization to access the data stored on your WD NAS device. For more detailed information, product comparisons and technical support regarding GoodSync for WD, please refer to:

Important:

Please click to view the Use of Third-Party Software or Websites disclaimer

Western Digital Technical Support does not provide setup, configuration or installation of GoodSync products. Please refer to GoodSync Support to obtain support for GoodSync software. Click Here for GoodSync Technical Support

Edit to add: WD Sync creates hidden folders where it stores a history of files synced. Sometimes errors in syncing arise due to files stored in these hidden folders. Some have to resort to deleting the contents of these hidden folder(s) to fix some WD Sync issues. Others simply get rid of the WD Sync software all together and use third party sync programs like Free File Sync (https://freefilesync.org/).

thanks for both these posts - I’ve tried GoodSync and found the free version quite limited. Apart form this issue, WDsync has worked for me OK for years - but I’ll take a look at freefilesync. Though if there was a way of just saying don’t back up this file it would be great.

You may want to check, if you haven’t already, the WD Sync help file to see what options there are available for skipping/ignoring specific files. I never used WD Sync (beyond a quick test of the software) due to these kinds of issues with it.

As a troubleshooting step (if you haven’t tried already), if you know which files WD Sync is failing to sync, move those files to another location that isn’t being monitored by WD Sync and see if WD Sync clears the sync error(s). Then move the files back and see if WD Sync will sync the files correctly.

Edit to add: Also just remembered this discussion on WD Sync exclusion file from 2015 that one could, I assume, still use to force exclusions of certain files from being synced by WD Sync. This could be another way to deal with problematic files that hang the WD Sync program.