WD Sync "Incorrect Password" Error

#1

I am trying to install WD Sync on a Macbook Pro running 10.10 Yosemite, when I get to the screen about adding a device I see my WDCloud and it allows me to check it, then it asks for a registered user password. I use my account, lets call it “randy” and password (that I set up for the account, not my WD online password) and it says this password is incorrect. It does the same with every registered user. I have also tried using my WD online password to no success. I have alops tried every registered user, creating a new user and using that password, and even using a user with no password.

I just want WD Sync to work…any help would be greatly appreciated, I am at my wits-end.

#2

Welcome to the Community.

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support
http://support.wdc.com/contact.aspx

Regards,

Trancer.

#3

Hi, i’ve got exactly the same probem! Did you find a way to fix it?

Thanks!

#4

No, I have been on with Level 2 Tech support and they could not figure out the issue! They are sending me a new MyCloud should be here today.

#5

Ah ok. Bummer! Good they send you a new one. Did you have to send yours back to them?

Thanks!

#6

i have this exact same issue…so a new device is supposed to fix it??

#7

me too… same problem…
i also tried to change username, change password but impossible to log in

#8

I created an account just to let you guys know that I solved the issue by logging into the mycloud browser and creating a brand new username and password there with a different email. Then I was able to finally get this functioning.

#9

I have the same problem running WD My Sync on OSX El Capitan, has anyone found a solution to this? I’ve tried deleting and recreating the user, enabling SSL on local network connections etc and have not had any luck.

#10

I have the exact same issue and was wondering if you ever got the problem fixed if so what did you do :slight_smile:

#11

I have the same problem too. I know it’s something to do with the Mac because the Windows version of WD Sync works fine on my PC, but when I enter the same user account and password in the Mac version it fails. I’m running Mac OS 10.11.4.

#12

I have the same problem. I can’t believe the solution is to start over with new hardware. We’re talking about login credentials for goodness sakes. Why does this not work???

#13

Had this issue the last couple of weeks and just finished a support call with WD with a fix. :smile:
After trying lots of things that didn’t work (adding/changing users, reinstalling firmware, reinstalling wd my sync, etc.) then he walked me through a SYSTEM RESTORE

  1. Log into your dashboard (e.g. http://wdmyclouddl2100.local)
  2. Go to Settings; then ‘Utilities’;
  3. Under ‘Restore to Default’, make sure ‘System Only’ is selected, then hit ‘Restore’
  4. Follow the instructions. You’ll have to set it up again including users but all your files and folders will still be there.
    Now try to setup the device in my sync and it should work.
    So glad I got this working (and thanks to WD support)
#14

Those who are looking for a solution for “Invalid Password” on Mac Book and iMac. here is the solution.

  1. Uninstall WD Sync
  2. Reinstall WD Sync
  3. Connect your Mac with a different Network(Not the network your WD Cloud is connected)
  4. Sign in to view all your MYcloud.com devices (Sign in and you will instantly see your drive associated with your account)
  5. Click on your device and it will instantly bypass user-Sign and your WD Sync will start working with User automatically logged in.

Regards

a