WD Softwares Access with NAT

I dont know maybe it is a basic problem but couldnt find out a solution then i need to ask.

I have a mycloud mirror. I like to access device with wd softwares ( mac,windows,mobile … ) over web however device’s external ip is forwarded with NAT to local ip of device. 21,80,8080,4443 ports are forwarded.

I can access device with ftp and also access to dashboard anywhere but wd softwares can not find the device if i m not in the same network with device.

If the problem is about ports which ports i need to allow (forward … whatever ) to device for softwares. if not what can i do ?

Any idea ?

With what software you want to access your My Cloud?

Port 21: OK for FTP access
Port 80: i think for the web interface; if so, this is NOT OK and not a good idea to open the webinterface for uncontrolled internet access
Port 8080: OK, relais port for the HTTP part of My Cloud
Port 4443: OK, relais port for the HTTPS part of My Cloud

Except port 21 for FTP, all theses ports can be changed to anything else on the internet WAN side but not on the internal LAN side.

Example for a port forwarding rule in your router:
External port 8080 to internal port 8080 to internal IP address of the My Cloud

Have you enabled the Port-Forwarding Section (Settings -> Network -> last option down at the bottom) within the My Cloud web interface?
What is stated below the cloud connection under Settings -> General ?

Thanks for answer,

With wd softwares i mean the softwares i get from http://support.wdc.com/downloads.aspx?lang=en for my device.

I have tried

  • WD My Cloud Desktop for Windows
  • WD My Cloud Desktop for Mac
  • Mobile App for android

Tring to connect with getting code. Not any response actually.

For the second question, i did not do anything to Port-Forwarding Section except tried WebDAV ports 4443 and 8080 same for external to local ports.

And forgot to mention that - also answer for your last question - , Connection Status under Cloud Connection and the status under Network - > Network Profile sometime calls connected and sometime not. However even it calls not connected i still can connect to the web interface of my cloud and ftp over internet. ( I also updated the firmware while its telling No Internet Connection ).

And i need to note that opened ports ( 21,80,8080,4443 ) are opened on one way ( just allowed from outside to inside connections ),

  • Here I need to ask IT department to do these ( network things opening ports etc. ) and doing this take times so i need to know what to do exactly -

Thanks for your help and patience.