WD SmartWare issues

I formatted my WD My Passport Ultra T3 and didn’t realise that I would have erased all the start up files, I then followed the instructions of unzipping the files and copying it back on my external drive and all went well. I then went to click on the WD SmartWare exe and it came up with the error “Application not started from drive” I’m hoping that someone may have had this issue and can help how I can get my drive working again. Thanks in advance John.

Hi, you can download the WD Smartware installer from WD website, as the one in the drive is designed to just install it on your computer.

Thanks for the post but I’ve tried all this already, all I need is the application software that came with the original unit “My Passport Ultra” but I’ve followed all the instructions on the WD download site. I’ve copied the correct file to the external drive but still no success. if you could supply a link for the application software of the External drive would be awesome. Thanks in advance.