WD Smartware Issue (v1.3.4.1) MacOS + Other Issues

OS X v 10.8.2


WD Smartware

WD Quick View

My Book Live Duo 4TB (Raid 1 2TB)


Ive got a few issues with the current setup of the device and some other small issues.

Smartware Issue

When launching the smartware application it only shows my local device (MacBook Air) however there is no display of the MBL & options to setup the drive are unavailable (Greyed out).

Ive tried reinstalling the software but this hasnt made any difference at all. Is this a software bug or an issue with my network configuration?

In “Finder” the MBL “renamed” device automatically maps, my time machine app can see it and is backing up as we speak and I can also view all folders within my profile when connected using my credentials.

DNS Name

Safari is not resolving the dns named entry for MBL however this works fine in Google Chrome - any ideas? Both browsers I would presume use the built in Network Settings within MacOSx

External Access

Ok, I think ive read a few threads but wanted to confirm this, if I enter for example my routers ip address xx.xxx.xxx.xx:80 and setup forwarding within my Sky Router for the static ip address of MBL I would expect the page to load (Console Page)

This however fails with the message: 

You don’t have permission to access /UI/ssh on this server.

Im presuming this is something to do with the network im on, so to prove my theory I entered the same address whilst on the same network and it loads fine. When attempting to access on iPhone 3G network it fails.

Is there a way around this? 

Is there a way of mapping a drive to a folder within the MBL from an external source? i.e. If Im at home and want to retrieve a file by just mapping a drive would I in theory need to create some sort of virtual network?

WD Setup Software

When downloading the above software from this URL (WD Learning Center) I run the setup however there is a warning advising that my firmware needs updating - well I visit my console and it advises its already up to date. Is this because Im using a different version of the WD Setup application that is only applicable for certain versions / certain countries?

Id appreciate any help you guys can offer and sorry if Im duplicating existing threads.



For the smartware version I will recommend using Time Machine as oppose to smartware for backup

I don’t think still works with Mac

about your other questions is best to post them on the MBL Forum