WD Smartware Activation Error

This seems to be a recurring error from at least 2 years ago and evidently it’s still not occured to anyone to fix it yet.

I was happy with the WD Smartware demo and felt it performed far better than any other backup software I’d ever used, and so naturally bought it once the trial expired. The problems began when I typed in my activation code and email and it presented me with this:

I purchased this software over a month ago and have tried activating it every single day since then. I have tried everything reccomended in the numerous topics that span this apparently common problem, but have yet been able to find a viable solution and my patience grows thin. Here are some of the more common solutions that I’ve tried:

  • Upgrading to WD Smartware 2.4.0. Apparently this version fixed this error, but considering I’m still getting it whilst running version 2.4.1 I think that may have been a lie.
  • Running the program as an aministrator. The problem persists.
  • Signing into the dropbox cloud thing. I tried this and needless to say I am still unable to use the activation code I spent nearly 20 quid on.
  • This program is not blocked by my firewall or any of my anti-virus programs.
  • Contacting WD Support. I tried contacting them via the website, but humorously and somewhat ironically I was blocked at every turn from doing so by various error messages, and gave up due to frustration. I think some people employed by WD need to be fired.

I really want to get this software up and running so I can start creating backups, but I don’t want to spend good money after bad. I think it seems only fair that if a solution is not found I should be offered a full refund for essentially buying a useless piece of software.

Thanks in advance for your help, I hope I don’t have to resort to a cracked version (although at this point I would feel absolutely no guilt in doing so).

By the way I’m running Windows 7 Home Premium 64bit if that helps at all.

Hello Uctions, welcome to the Community. Sorry to hear you had a bad experience with the activation process. For this case I recommend you to contact tech support directly by phone, I’m sure they can help you narrow down the cause of the problem.